Project

General

Profile

Bug #5563

Fix bug in drb tests if hostname does not resolve to a local IP

Added by Jeremy Evans about 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 1.9.3p0 (2011-10-30 revision 33570) [i386-openbsd]
Backport:
[ruby-core:40713]

Description

3 of the drb tests leave the hostname part of the druby URI empty instead of using localhost. When a hostname is not provided, ruby uses the system hostname, which usually resolves to a local IP address, but not always. This causes the tests to fail if the system hostname doesn't resolve to a local IP address. The tests also appear to hang, since the connection timeout is 100 seconds.

The attached patch fixes this case by using localhost as the hostname in the 3 tests that did not already do that, making them consistent with the other tests.

test_drb_localhost.diff View (1.24 KB) Jeremy Evans, 11/04/2011 01:57 AM

History

#1 [ruby-core:43207] Updated by Koichi Sasada over 4 years ago

  • Assignee set to Masatoshi Seki

#2 Updated by Shyouhei Urabe over 4 years ago

  • Status changed from Open to Assigned

#3 [ruby-core:55942] Updated by Jeremy Evans over 3 years ago

This bug can be closed. Bug #7311 was a duplicate of this bug with the exact same patch I provided, and the patch was applied at r41916.

#4 [ruby-core:55948] Updated by Zachary Scott over 3 years ago

  • Status changed from Assigned to Closed

Thanks Jeremy!

Also available in: Atom PDF