Project

General

Profile

Bug #5703

Ruby 1.9.3p0 segmentation fault (during autoload?)

Added by brynary (Bryan Helmkamp) almost 8 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Target version:
-
ruby -v:
-
Backport:
[ruby-core:41463]

Description

I've been getting intermittent segfaults that appear to be coming out of autoload. Originally, I experienced them on 1.9.2p290, but they persisted after upgrading to 1.9.3p0. I thought the issue might have been #5047, but it seems not.

Here's an example:

/data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/elements/content_type_element.rb:3: [BUG] Segmentation fault
ruby 1.9.3p0 (2011-10-30 revision 33570) [i686-linux]

-- Control frame information -----------------------------------------------
c:0084 p:0011 s:0353 b:0353 l:000352 d:000352 CLASS /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/elements/content_type_element.rb:3
c:0083 p:0009 s:0351 b:0351 l:000350 d:000350 TOP /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/elements/content_type_element.rb:2
c:0082 p:---- s:0349 b:0349 l:000348 d:000348 FINISH
c:0081 p:0027 s:0347 b:0347 l:000346 d:000346 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/fields/content_type_field.rb:37
c:0080 p:0055 s:0344 b:0344 l:000343 d:000343 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/fields/content_type_field.rb:31
c:0079 p:0165 s:0340 b:0340 l:000339 d:000339 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/fields/content_type_field.rb:23
c:0078 p:---- s:0335 b:0335 l:000334 d:000334 FINISH
c:0077 p:---- s:0333 b:0333 l:000332 d:000332 CFUNC :new
c:0076 p:0982 s:0328 b:0328 l:000327 d:000327 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/field.rb:211
c:0075 p:0021 s:0322 b:0320 l:000319 d:000319 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/field.rb:146
c:0074 p:0057 s:0313 b:0313 l:000312 d:000312 METHOD /data/codeclimate/shared/bundled_gems/ruby/1.9.1/gems/mail-2.3.0/lib/mail/field.rb:79
c:0073 p:---- s:0307 b:0307 l:000306 d:000306 FINISH

Full output is at: https://raw.github.com/gist/5c7921f33908a3780779/d0f99051bda6f8cefbaf390ad54f13de09d24f5a/gistfile1.txt

The segfault occurs at different lines each time, but it always seems to be associated with loading new code (note rb_autoload_load in the C-level stack). The mail gem does not appear to have any C extensions, so I don't think it is an issue with that gem.

If more information is needed, I can try to collect, however it's fairly difficult because it occurs intermittently and in a daemon (Resque).

Any help would be appreciated.

-Bryan

History

#1

Updated by ko1 (Koichi Sasada) over 7 years ago

  • Status changed from Open to Assigned
  • Assignee set to nahi (Hiroshi Nakamura)

Updated by naruse (Yui NARUSE) over 6 years ago

  • Status changed from Assigned to Feedback
  • Priority changed from 5 to Normal

Could you provide a reproducible code?

Updated by mame (Yusuke Endoh) over 1 year ago

  • Status changed from Feedback to Rejected

1.9.3 has been already dead.

Also available in: Atom PDF