Project

General

Profile

Bug #5752

Array#delete_if side effects due to changeset r32360

Added by Thomas Leitner almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]
[ruby-core:41616]

Description

It seems that the changeset r32360 introduced another side effect. Here are two IRB sessions, one in ruby-1.9.2-p136 and the other in ruby-1.9.3-p0:

ruby-1.9.2-p136 :001 > x = [1,2,3,4,5,6,7,8,9]
=> [1, 2, 3, 4, 5, 6, 7, 8, 9]
ruby-1.9.2-p136 :002 > x.delete_if {|i| i == x[i-1]}
=> []

ruby-1.9.3-p0 :001 > x = [1,2,3,4,5,6,7,8,9]
=> [1, 2, 3, 4, 5, 6, 7, 8, 9]
ruby-1.9.3-p0 :002 > x.delete_if {|i| i == x[i-1]}
=> [2, 3, 4, 5, 6, 7, 8, 9]

If this is indeed the intended behaviour, it should probably be documented clearly that the array is changed instantly every time the block is called and not after the iteration is over.

array.c.patch View - fix delete_if (719 Bytes) Yura Sokolov, 12/14/2011 07:03 PM


Related issues

Related to Ruby trunk - Feature #10714: Array#reject! nonlinear performance problem Closed 01/08/2015

Associated revisions

Revision 34048
Added by Nobuyoshi Nakada almost 5 years ago

  • array.c (rb_ary_reject_bang, rb_ary_delete_if): update rdoc. documentation from Thomas Leitner in . [Bug #5752]

Revision 34048
Added by Nobuyoshi Nakada almost 5 years ago

  • array.c (rb_ary_reject_bang, rb_ary_delete_if): update rdoc. documentation from Thomas Leitner in . [Bug #5752]

Revision 34048
Added by Nobuyoshi Nakada almost 5 years ago

  • array.c (rb_ary_reject_bang, rb_ary_delete_if): update rdoc. documentation from Thomas Leitner in . [Bug #5752]

History

#1 [ruby-core:41646] Updated by Yura Sokolov almost 5 years ago

Actually, it were next changeset r32373

#3 [ruby-core:41664] Updated by Nobuyoshi Nakada almost 5 years ago

  • Category changed from core to doc
  • Status changed from Open to Closed

#4 [ruby-core:67483] Updated by Akira Tanaka over 1 year ago

  • Related to Feature #10714: Array#reject! nonlinear performance problem added

Also available in: Atom PDF