Project

General

Profile

Feature #5820

Merge Onigmo to Ruby 2.0

Added by naruse (Yui NARUSE) over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-dev:45057]

Description

Ruby 1.9 では正規表現エンジンや M17N の基盤として Oniguruma を用いています。
これを 2.0 では Oniguruma の改造版である、k-takata さんの Onigmo に置き換えようという話です。
https://github.com/k-takata/Onigmo/tree/tmp/ruby-2.0.x

この取り込みによる影響は以下の通りです。

  • 100%互換 (既存のテストが全て無修正で通る)
  • いくつかの新機能 [ruby-dev:44410]
    • 正規表現   * \K, \R, \X, (?(cond)yes|no), \g, \g<+n>, (?au)   * Perl 5.10互換の名前参照(←Rubyには不要でしょう。)
    • Shift_JIS, EUC-JPで、全角アルファベットなどの大文字小文字同一視検索に対応。
    • Shift_JIS, EUC-JPで、\p{Han}, \p{Latin}, \p{Greek}, \p{Cyrillic} に対応。
    • 最適化

現状は POSIX 文字クラスに非互換があり、それが解決されればマージ可能と認識しています。


Files


Related issues

Related to Ruby master - Bug #5208: \b and \B don't match properlyClosednaruse (Yui NARUSE)08/21/2011Actions

Also available in: Atom PDF