Project

General

Profile

Backport #6043

compile error for 1.9.3-p125 on OS X 10.7.3 with Xcode 4.2.1, gcc not found

Added by jahapro (Jan Harmsen) about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:42710]

Description

Configure aborts due to not finding gcc, configure script looks for gcc-4.2 but there is only /usr/bin/gcc

/usr/bin/gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)

For a successfule compile, param '--with-gcc=clang' needs to be specified:

rvm install ruby-1.9.3-p125 --with-gcc=clang

will successfully install ruby-1.9.3-p125


Related issues

Related to Ruby master - Bug #5082: test_context_switch(TestMarshal) was failed on OS X 10.7 (Lion)Closedkosaki (Motohiro KOSAKI)07/23/2011Actions

Also available in: Atom PDF