Bug #6281

1.9.3-p125 crashes when using therubyracer 0.9.10

Added by Ben Rogers about 2 years ago. Updated about 1 year ago.

[ruby-core:44288]
Status:Rejected
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-darwin11.3.0] Backport:

Description

I'm on Mac OS X 10.7.3, and I'm unable to run 1.9.3-p125 when I require therubyracer 0.9.10. Note that ruby 1.9.3-p0 works just fine.

Reproducing code:

#!/home/directory/.rvm/rubies/ruby-1.9.3-p125/bin/ruby

require 'v8'

puts 'hi'

Download and use:

http://rubygems.org/gems/therubyracer/versions/0.9.10

Running that script gives the following output:

/home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/ext/v8/v8.bundle: [BUG] Segmentation fault
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-darwin11.3.0]

-- Control frame information -----------------------------------------------
c:0012 p:-17528248670772 s:0039 b:0039 l:000038 d:000038 TOP

c:0011 p:---- s:0037 b:0037 l:000036 d:000036 CFUNC :require
c:0010 p:0036 s:0033 b:0033 l:000032 d:000032 METHOD /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb:36
c:0009 p:0025 s:0026 b:0026 l:000025 d:000025 CLASS /home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/lib/v8.rb:6
c:0008 p:0098 s:0024 b:0024 l:000023 d:000023 TOP /home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/lib/v8.rb:4
c:0007 p:---- s:0022 b:0022 l:000021 d:000021 FINISH
c:0006 p:---- s:0020 b:0020 l:000019 d:000019 CFUNC :require
c:0005 p:0089 s:0016 b:0016 l:000012 d:000015 BLOCK /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb:60
c:0004 p:0158 s:0013 b:0013 l:000012 d:000012 METHOD /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb:35
c:0003 p:0011 s:0006 b:0006 l:002068 d:001d78 EVAL ./rubyracer-problem-with-p125.rb:3
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:002068 d:002068 TOP

-- Ruby level backtrace information ----------------------------------------
./rubyracer-problem-with-p125.rb:3:in <main>'
/home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in
require'
/home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb:60:in rescue in require'
/home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
require'
/home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/lib/v8.rb:4:in <top (required)>'
/home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/lib/v8.rb:6:in
module:V8'
/home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb:36:in require'
/home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require'

-- C level backtrace information -------------------------------------------

See Crash Report log file under ~/Library/Logs/CrashReporter or
/Library/Logs/CrashReporter, for the more detail of.

-- Other runtime information -----------------------------------------------

  • Loaded script: ./rubyracer-problem-with-p125.rb

  • Loaded features:

    0 enumerator.so
    1 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/1.9.1/x8664-darwin11.3.0/enc/encdb.bundle
    2 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/1.9.1/x86
    64-darwin11.3.0/enc/trans/transdb.bundle
    3 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/defaults.rb
    4 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/1.9.1/x86
    64-darwin11.3.0/rbconfig.rb
    5 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/deprecate.rb
    6 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site
    ruby/1.9.1/rubygems/exceptions.rb
    7 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/customrequire.rb
    8 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems.rb
    9 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site
    ruby/1.9.1/rubygems/version.rb
    10 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/requirement.rb
    11 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site
    ruby/1.9.1/rubygems/platform.rb
    12 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/siteruby/1.9.1/rubygems/specification.rb
    13 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site
    ruby/1.9.1/rubygems/pathsupport.rb
    14 /home/directory.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site
    ruby/1.9.1/rubygems/dependency.rb
    15 /home/directory.rvm/gems/ruby-1.9.3-p125/gems/therubyracer-0.9.10/lib/v8/version.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

From

Process: ruby [18120]
Path: /Users/USER/*/ruby
Identifier: ruby
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: bash [18119]

Date/Time: 2012-04-11 10:39:14.756 -0500
OS Version: Mac OS X 10.7.3 (11D50d)
Report Version: 9

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXCBADACCESS (SIGABRT)
Exception Codes: KERNINVALIDADDRESS at 0x0000000000000000

VM Regions Near 0:
-->
__TEXT 000000010ded0000-000000010ded1000 [ 4K] r-x/rwx SM=COW /Users/USER/*

Application Specific Information:
objc[18120]: garbage collection is OFF
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystemkernel.dylib 0x00007fff88ce4ce2 _pthreadkill + 10
1 libsystem
c.dylib 0x00007fff8abc67d2 pthreadkill + 95
2 libsystem
c.dylib 0x00007fff8abb7a7a abort + 143
3 libruby.1.9.1.dylib 0x000000010df127d4 rbbug + 212
4 libruby.1.9.1.dylib 0x000000010dfdb6bf sigsegv + 127
5 libsystem
c.dylib 0x00007fff8ac18cfa sigtramp + 26
6 libruby.1.dylib 0x000000010e7da5f9 st
lookup + 26
7 libruby.1.dylib 0x000000010e7ac42c rbintern + 53
8 libruby.1.dylib 0x000000010e767e86 rb
definemodule + 12
9 v8.bundle 0x000000010e366e59 rr
defineclass(char const*, unsigned long) + 25 (rr.cpp:17)
10 v8.bundle 0x000000010e368ec6 rr
inithandle() + 31 (v8handle.cpp:157)
11 v8.bundle 0x000000010e367326 Initv8 + 25 (v8.cpp:30)
12 libruby.1.9.1.dylib 0x000000010ded812c dln
load + 236 (dln.c:1523)
13 libruby.1.9.1.dylib 0x000000010e0424a9 rbvmcallcfunc + 201 (vminsnhelper.c:100)
14 libruby.1.9.1.dylib 0x000000010df1b6b2 rbrequiresafe + 1058 (load.c:623)
15 libruby.1.9.1.dylib 0x000000010e059257 vmcallmethod + 999 (vminsnhelper.c:404)
16 libruby.1.9.1.dylib 0x000000010e04734f vm
execcore + 18767 (insns.def:1015)
17 libruby.1.9.1.dylib 0x000000010e04bfb3 vm
exec + 1459 (vm.c:1220)
18 libruby.1.9.1.dylib 0x000000010e04c440 rbiseqeval + 368 (vm.c:1448)
19 libruby.1.9.1.dylib 0x000000010df1a32b rbloadinternal + 331 (load.c:312)

20 libruby.1.9.1.dylib 0x000000010df1b6ec rbrequiresafe + 1116 (load.c:619)
21 libruby.1.9.1.dylib 0x000000010e059257 vmcallmethod + 999 (vminsnhelper.c:404)
22 libruby.1.9.1.dylib 0x000000010e04734f vm
execcore + 18767 (insns.def:1015)
23 libruby.1.9.1.dylib 0x000000010e04bfb3 vm
exec + 1459 (vm.c:1220)
24 libruby.1.9.1.dylib 0x000000010e04c2ac rbiseqevalmain + 508 (vm.c:1462)
25 libruby.1.9.1.dylib 0x000000010df173f2 ruby
execinternal + 178 (eval.c:204)
26 libruby.1.9.1.dylib 0x000000010df19eec ruby
run_node + 60 (eval.c:251)
27 ruby 0x000000010ded0edf main + 79 (main.c:40)
28 ruby 0x000000010ded0e84 start + 52

Thread 1:
0 libsystemkernel.dylib 0x00007fff88ce4df2 _select + 10
1 libruby.1.9.1.dylib 0x000000010e0637af threadtimer + 399 (threadpthread.c:1155)
2 libsystemc.dylib 0x00007fff8abc48bf _pthreadstart + 335
3 libsystemc.dylib 0x00007fff8abc7b75 threadstart + 13

Thread 2:: SamplerThread
0 libsystemkernel.dylib 0x00007fff88ce4e42 _semwaitsignal + 10
1 libsystem
c.dylib 0x00007fff8ab7adea nanosleep + 164
2 libsystemc.dylib 0x00007fff8ab7abb5 usleep + 53
3 v8.bundle 0x000000010e491875 v8::internal::SamplerThread::Run() + 131
4 v8.bundle 0x000000010e490d10 _ZN2v88internalL11ThreadEntryEPv + 80
5 libsystem
c.dylib 0x00007fff8abc48bf pthreadstart + 335
6 libsystemc.dylib 0x00007fff8abc7b75 threadstart + 13

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000006 rcx: 0x000000010e356938 rdx: 0x0000000000000000
rdi: 0x000000000000060b rsi: 0x0000000000000006 rbp: 0x000000010e356960 rsp: 0x000000010e356938
r8: 0x00007fff78a05fb8 r9: 0x000000010e3564c8 r10: 0x00007fff88ce4d0a r11: 0xffffff80002d8220
r12: 0x00007f88ea10e8f0 r13: 0x00007f88ea10e8f0 r14: 0x00007fff78a08960 r15: 0x0000000000000000
rip: 0x00007fff88ce4ce2 rfl: 0x0000000000000246 cr2: 0x000000010e355a50
Logical CPU: 0

Binary Images:
0x10ded0000 - 0x10ded0fff +ruby (??? - ???) /Users/USER//ruby
0x10ded7000 - 0x10e0fbff7 +libruby.1.9.1.dylib (1.9.1 - compatibility 1.9.1) /Users/USER/
/libruby.1.9.1.dylib
0x10e35d000 - 0x10e35efff +encdb.bundle (??? - ???) /Users/USER//encdb.bundle
0x10e361000 - 0x10e362ff7 +transdb.bundle (??? - ???) /Users/USER/
/transdb.bundle
0x10e366000 - 0x10e646fe7 +v8.bundle (??? - ???) /Users/USER/*/v8.bundle

   0x10e75d000 -        0x10e823fff  libruby.1.dylib (1.8.7 - compatibility 1.8.0) <DD1D66A8-20C6-3EC5-9261-446BD96BEB48> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/libruby.1.dylib
0x7fff6dad0000 -     0x7fff6db04baf  dyld (195.6 - ???) <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld
0x7fff88cce000 -     0x7fff88ceefff  libsystem_kernel.dylib (1699.24.8 - compatibility 1.0.0) <C56819BB-3779-3726-B610-4CF7B3ABB6F9> /usr/lib/system/libsystem_kernel.dylib
0x7fff8922a000 -     0x7fff89234ff7  liblaunch.dylib (392.35.0 - compatibility 1.0.0) <8F8BB206-CECA-33A5-A105-4A01C3ED5D23> /usr/lib/system/liblaunch.dylib
0x7fff894ef000 -     0x7fff894f1fff  libquarantine.dylib (36.2.0 - compatibility 1.0.0) <48656562-FF20-3B55-9F93-407ACA7341C0> /usr/lib/system/libquarantine.dylib
0x7fff89a4c000 -     0x7fff89a87fff  libsystem_info.dylib (??? - ???) <35F90252-2AE1-32C5-8D34-782C614D9639> /usr/lib/system/libsystem_info.dylib
0x7fff8a2b4000 -     0x7fff8a2f6ff7  libcommonCrypto.dylib (55010.0.0 - compatibility 1.0.0) <BB770C22-8C57-365A-8716-4A3C36AE7BFB> /usr/lib/system/libcommonCrypto.dylib
0x7fff8aada000 -     0x7fff8aae0ff7  libunwind.dylib (30.0.0 - compatibility 1.0.0) <1E9C6C8C-CBE8-3F4B-A5B5-E03E3AB53231> /usr/lib/system/libunwind.dylib
0x7fff8ab76000 -     0x7fff8ac53fef  libsystem_c.dylib (763.12.0 - compatibility 1.0.0) <FF69F06E-0904-3C08-A5EF-536FAFFFDC22> /usr/lib/system/libsystem_c.dylib
0x7fff8ac54000 -     0x7fff8ac71fff  libxpc.dylib (77.18.0 - compatibility 1.0.0) <26C05F31-E809-3B47-AF42-1460971E3AC3> /usr/lib/system/libxpc.dylib
0x7fff8accf000 -     0x7fff8acd4fff  libcache.dylib (47.0.0 - compatibility 1.0.0) <1571C3AB-BCB2-38CD-B3B2-C5FC3F927C6A> /usr/lib/system/libcache.dylib
0x7fff8ad29000 -     0x7fff8ad29fff  libkeymgr.dylib (23.0.0 - compatibility 1.0.0) <61EFED6A-A407-301E-B454-CD18314F0075> /usr/lib/system/libkeymgr.dylib
0x7fff8b4a2000 -     0x7fff8b4aafff  libsystem_dnssd.dylib (??? - ???) <998E3778-7B43-301C-9053-12045AB8544D> /usr/lib/system/libsystem_dnssd.dylib
0x7fff8c412000 -     0x7fff8c417fff  libcompiler_rt.dylib (6.0.0 - compatibility 1.0.0) <98ECD5F6-E85C-32A5-98CD-8911230CB66A> /usr/lib/system/libcompiler_rt.dylib
0x7fff8cc96000 -     0x7fff8cc97fff  libdnsinfo.dylib (395.7.0 - compatibility 1.0.0) <37FEFE78-BCB5-37EC-8E99-747469BCA4C7> /usr/lib/system/libdnsinfo.dylib
0x7fff8ce5c000 -     0x7fff8ce60fff  libmathCommon.A.dylib (2026.0.0 - compatibility 1.0.0) <FF83AFF7-42B2-306E-90AF-D539C51A4542> /usr/lib/system/libmathCommon.A.dylib
0x7fff8d038000 -     0x7fff8d039ff7  libsystem_sandbox.dylib (??? - ???) <5087ADAD-D34D-3844-9D04-AFF93CED3D92> /usr/lib/system/libsystem_sandbox.dylib
0x7fff8de01000 -     0x7fff8de06ff7  libsystem_network.dylib (??? - ???) <5DE7024E-1D2D-34A2-80F4-08326331A75B> /usr/lib/system/libsystem_network.dylib
0x7fff8de28000 -     0x7fff8de9dff7  libc++.1.dylib (19.0.0 - compatibility 1.0.0) <C0EFFF1B-0FEB-3F99-BE54-506B35B555A9> /usr/lib/libc++.1.dylib
0x7fff8e002000 -     0x7fff8e0e6e5f  libobjc.A.dylib (228.0.0 - compatibility 1.0.0) <871E688B-CF57-3BC7-80D6-F6476DFF109B> /usr/lib/libobjc.A.dylib
0x7fff8e51c000 -     0x7fff8e527ff7  libc++abi.dylib (14.0.0 - compatibility 1.0.0) <8FF3D766-D678-36F6-84AC-423C878E6D14> /usr/lib/libc++abi.dylib
0x7fff8f82e000 -     0x7fff8f82fff7  libsystem_blocks.dylib (53.0.0 - compatibility 1.0.0) <8BCA214A-8992-34B2-A8B9-B74DEACA1869> /usr/lib/system/libsystem_blocks.dylib
0x7fff90aeb000 -     0x7fff90b5efff  libstdc++.6.dylib (52.0.0 - compatibility 7.0.0) <6BDD43E4-A4B1-379E-9ED5-8C713653DFF2> /usr/lib/libstdc++.6.dylib

0x7fff90b6d000 -     0x7fff90b7bfff  libdispatch.dylib (187.7.0 - compatibility 1.0.0) <712AAEAC-AD90-37F7-B71F-293FF8AE8723> /usr/lib/system/libdispatch.dylib
0x7fff90e20000 -     0x7fff90e4dfe7  libSystem.B.dylib (159.1.0 - compatibility 1.0.0) <7BEBB139-50BB-3112-947A-F4AA168F991C> /usr/lib/libSystem.B.dylib
0x7fff91930000 -     0x7fff91939ff7  libsystem_notify.dylib (80.1.0 - compatibility 1.0.0) <A4D651E3-D1C6-3934-AD49-7A104FD14596> /usr/lib/system/libsystem_notify.dylib
0x7fff937ea000 -     0x7fff93838fff  libauto.dylib (??? - ???) <D8AC8458-DDD0-3939-8B96-B6CED81613EF> /usr/lib/libauto.dylib
0x7fff9390d000 -     0x7fff9390efff  libunc.dylib (24.0.0 - compatibility 1.0.0) <337960EE-0A85-3DD0-A760-7134CF4C0AFF> /usr/lib/system/libunc.dylib
0x7fff94284000 -     0x7fff94288fff  libdyld.dylib (195.5.0 - compatibility 1.0.0) <380C3F44-0CA7-3514-8080-46D1C9DF4FCD> /usr/lib/system/libdyld.dylib
0x7fff94965000 -     0x7fff9496cfff  libcopyfile.dylib (85.1.0 - compatibility 1.0.0) <0AB51EE2-E914-358C-AC19-47BC024BDAE7> /usr/lib/system/libcopyfile.dylib
0x7fff94da4000 -     0x7fff94da5ff7  libremovefile.dylib (21.1.0 - compatibility 1.0.0) <739E6C83-AA52-3C6C-A680-B37FE2888A04> /usr/lib/system/libremovefile.dylib
0x7fff95124000 -     0x7fff9512afff  libmacho.dylib (800.0.0 - compatibility 1.0.0) <165514D7-1BFA-38EF-A151-676DCD21FB64> /usr/lib/system/libmacho.dylib

External Modification Summary:
Calls made by other processes targeting this process:
taskforpid: 0
threadcreate: 0
thread
setstate: 0
Calls made by this process:
task
forpid: 0
thread
create: 0
threadsetstate: 0
Calls made by all processes on this machine:
taskforpid: 2905
threadcreate: 0
thread
set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=59.5M resident=19.2M(32%) swappedoutorunallocated=40.3M(68%)
Writable regions: Total=51.9M written=5964K(11%) resident=8912K(17%) swapped
out=0K(0%) unallocated=43.2M(83%)

REGION TYPE VIRTUAL
=========== =======
MALLOC 39.3M
MALLOC guard page 16K
Memory tag=255 576.3M
Memory tag=255 (reserved) 1024K reserved VM address space (unallocated)
STACK GUARD 8K
Stack 64.5M
VMALLOCATE 4K
_
DATA 1000K
_LINKEDIT 49.1M
_
TEXT 10.4M
shared memory 12K
=========== =======
TOTAL 741.7M
TOTAL, minus reserved VM space 740.7M


Related issues

Related to ruby-trunk - Bug #6283: Segmentation fault pg_ext.bundle Assigned 04/12/2012

History

#1 Updated by Yui NARUSE about 2 years ago

  • Status changed from Open to Feedback

I can't reproduce it.
I think you should reinstall therubyracer.

Anyone can do?

#2 Updated by Eric Hodel about 1 year ago

  • Status changed from Feedback to Rejected

There has been no feedback from the submitter so I am marking this as rejected.

Also available in: Atom PDF