Bug #6329

Can't use Ruby 1.9.3 as baseruby when cross compiling (MinGW)

Added by Luis Lavena over 3 years ago. Updated over 3 years ago.

[ruby-core:44492]
Status:Closed
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:2.0.0 r35415 Backport:

Description

Hello,

I believe this was covered before on older issues, but this is showing again.

$ make
CC = i686-w64-mingw32-gcc
LD = ld
LDSHARED = i686-w64-mingw32-gcc -shared
CFLAGS = -O3 -fno-omit-frame-pointer -ggdb -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Wunused-variable -Werror=pointer-arith -Werror=write-strings -Werror=declaration-after-statement -Werror=implicit-function-declaration
XCFLAGS = -include ruby/config.h -include ruby/missing.h -D_FORTIFY_SOURCE=2 -fno-strict-overflow -DRUBY_EXPORT
CPPFLAGS = -D_WIN32_WINNT=0x0501 -I. -I.ext/include/i386-mingw32 -I../include -I..
DLDFLAGS = -Wl,--enable-auto-image-base,--enable-auto-import -Wl,--out-implib=libmsvcrt-ruby200.dll.a msvcrt-ruby200.def -Wl,--stack,0x00200000,--enable-auto-import

SOLIBS = msvcrt-ruby200.res.o -lshell32 -lws2_32 -limagehlp

config.status: creating i386-mingw32-fake.rb
rbconfig.rb updated
generating enc.mk
/Users/luis/projects/oss/ruby/xbuild/rbconfig.rb:7:in <module:RbConfig>': ruby lib version (2.0.0) doesn't match executable version (1.9.3) (RuntimeError)
from /Users/luis/projects/oss/ruby/xbuild/rbconfig.rb:5:in
'
from /Users/luis/.rbenv/versions/1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems.rb:31:in require'
from /Users/luis/.rbenv/versions/1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems.rb:31:in
'
from internal:gem_prelude:1:in require'
from <internal:gem_prelude>:1:in
'
make: *** [enc.mk] Error 1

Switching to 1.8.7-p358 solves the issue.

No --with-baseruby was provided during configure phase, ruby was available in the $PATH

Associated revisions

Revision 35431
Added by Nobuyoshi Nakada over 3 years ago

  • configure.in: disable rubygems not to load rbconfig.rb before fake.rb. [Bug #6329]

Revision 35431
Added by Nobuyoshi Nakada over 3 years ago

  • configure.in: disable rubygems not to load rbconfig.rb before fake.rb. [Bug #6329]

History

#1 Updated by Yusuke Endoh over 3 years ago

  • Status changed from Open to Assigned
  • Assignee set to Nobuyoshi Nakada

#2 Updated by Nobuyoshi Nakada over 3 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r35431.
Luis, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • configure.in: disable rubygems not to load rbconfig.rb before fake.rb. [Bug #6329]

Also available in: Atom PDF