Project

General

Profile

Bug #6514

Abort trap: 6 running rspec on rdf.rb

Added by Gregg Kellogg about 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
ruby -v:
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.3.0]
Backport:
[ruby-core:45315]

Description

Running RSpec on http://github.com/ruby-rdf/rdf/spec reliably generates the Abort trap.

To repeat:

  1. git clone git://github.com/ruby-rdf/rdf.git
  2. cd rdf
  3. bundle install
  4. rspec spec

It does not seem to happen when running a subset of the spec files.

ruby_2012-05-29-174158_Greggs-iMac.crash (18.6 KB) Gregg Kellogg, 05/30/2012 09:57 AM

History

#1 [ruby-core:45340] Updated by Yusuke Endoh almost 4 years ago

  • Status changed from Open to Feedback
  • Assignee set to sorah Shota Fukumori

I cannot reproduce.

$ git clone git://github.com/ruby-rdf/rdf.git
Cloning into 'rdf'...
remote: Counting objects: 6187, done.
remote: Compressing objects: 100% (1828/1828), done.
remote: Total 6187 (delta 4496), reused 5949 (delta 4280)
Receiving objects: 100% (6187/6187), 1.01 MiB | 258 KiB/s, done.
Resolving deltas: 100% (4496/4496), done.

$ cd rdf

$ bundle install
The path /tmp/rdf-spec does not exist.

$ rspec spec
The path /tmp/rdf-spec does not exist.

--
Yusuke Endoh mame@tsg.ne.jp

#2 Updated by Tomoyuki Chikanaga almost 4 years ago

Hi,

It seems that step 1.5
$ git clone git://github.com/ruby-rdf/rdf.git
is required.

But I also cannot reproduce abort trap with ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.3.0].

Mr Gregg, could you tell us the messages on your terminal too?

#3 Updated by Yui NARUSE over 3 years ago

  • Target version changed from 1.9.3 to next minor

#4 [ruby-core:57525] Updated by sorah Shota Fukumori over 2 years ago

  • Status changed from Feedback to Rejected

Closing this due to no feedbacks.

Also available in: Atom PDF