Bug #6645

Segmentation fault in net/http.rb

Added by Yuki Nishijima almost 2 years ago. Updated about 1 year ago.

[ruby-core:45834]
Status:Rejected
Priority:Normal
Assignee:-
Category:lib
Target version:-
ruby -v:ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux] Backport:

Description

=begin
Today I ran into the problem titled above. The error message looks like this:

/home/yuki/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:761: [BUG] Segmentation fault
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]

-- Control frame information -----------------------------------------------
c:0066 p:0015 s:0266 b:0264 l:000263 d:000263 METHOD /home/yuki/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:761
c:0065 p:0011 s:0256 b:0256 l:000255 d:000255 METHOD /home/yuki/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:755
c:0064 p:0048 s:0253 b:0253 l:000252 d:000252 METHOD /home/yuki/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:744
c:0063 p:0182 s:0250 b:0250 l:000249 d:000249 METHOD /home/yuki/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/net/http.rb:557

You can find the full stack trace here: ((URL:https://gist.github.com/2988740))

I don't know how I can help the project here since this is my first time to report a bug, but let me know if you would like me to do something. Thanks!
=end

History

#1 Updated by Eric Hodel almost 2 years ago

You have many C extensions loaded, one of these may be causing the crash. Can you reproduce this crash without loading so many extensions? I see pg, hpricot, bson_ext, ruby-prof, nokogiri, bcrypt-ruby, gherkin, eventmachine.

Can you reproduce it with capybara-webkit and no other C extensions?

Can you reproduce it without any C extensions?

#2 Updated by Yui NARUSE almost 2 years ago

  • Status changed from Open to Feedback

The C level stack trace says someone gives Ruby a broken array.
Anyone can make a small reproducible code?

#3 Updated by Yuki Nishijima almost 2 years ago

sorry for my late reply.

It was a bit difficult for me to reproduce this problem with a minimal set of code, and haven't found the one which gives a broken array.
Anyone can reproduce this?

#4 Updated by Yusuke Endoh over 1 year ago

At least, we need your whole source code to reproduce. Can you provide?

Yusuke Endoh mame@tsg.ne.jp

#5 Updated by Eric Hodel about 1 year ago

  • Category set to lib
  • Status changed from Feedback to Rejected

No feedback that allows us to reproduce this so I'm rejecting it.

Also available in: Atom PDF