Project

General

Profile

Bug #7144

[mingw] 1.9.3 backport r37138 breaks build

Added by jonforums (Jon Forums) over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3p277 (2012-09-25 revision 37029) [i386-mingw32]
Backport:
[ruby-core:47918]

Description

On ruby_1_9_3@r37144 (but not trunk@37146) the following error occurs with both GCC 4.6.2 (mingw) and GCC 4.7.2 (mingw-w64)

compiling ../../../../Jenkins/workspace/ruby-1_9_3-svn/io.c
../../../../Jenkins/workspace/ruby-1_9_3-svn/io.c: In function 'rb_cloexec_fcntl_dupfd':
../../../../Jenkins/workspace/ruby-1_9_3-svn/io.c:213:21: error: 'F_DUPFD' undeclared (first use in this function)


Related issues

Is duplicate of Backport193 - Backport #6127: IO#ioctl range error in 1.9.3Closednaruse (Yui NARUSE)03/10/2012Actions

Also available in: Atom PDF