Project

General

Profile

Bug #7313

test_initialize(TestEnumerator) fails

Added by Vit Ondruch about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 2.0.0dev (2012-11-08 trunk 37564) [x86_64-linux]
[ruby-core:49107]

Description

=begin
test_initialize(TestEnumerator):
TypeError: can't convert Array into Integer
/builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in initialize'
/builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in
new'
/builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in `test_initialize'
=end


Related issues

Duplicates Ruby trunk - Bug #7298: Behavior of Enumerator.new different between 1.9.3 and 2.0.0 Closed 11/07/2012

History

#1 [ruby-core:49109] Updated by Yusuke Endoh about 4 years ago

  • Status changed from Open to Assigned
  • Assignee set to Marc-Andre Lafortune
  • Target version set to 2.0.0

Marc-Andre, do you know anything about this?

--
Yusuke Endoh mame@tsg.ne.jp

#2 [ruby-core:49111] Updated by Marc-Andre Lafortune about 4 years ago

  • Status changed from Assigned to Closed

Duplicate of #7298, see

Also available in: Atom PDF