Project

General

Profile

Feature #7426

Update Rdoc

Added by Yusuke Endoh about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
[ruby-core:49949]

Description

Eric Hodel is planning to update Rdoc by the end of November.
See .

Eric, what's the status?

--
Yusuke Endoh mame@tsg.ne.jp

History

#1 [ruby-core:49961] Updated by Eric Hodel about 4 years ago

I have one more issue to evaluate before I can release. I will finish tonight, test RDoc against various gems tomorrow for regressions, then commit Sunday.

#2 [ruby-core:49997] Updated by Yusuke Endoh about 4 years ago

Thank you!

--
Yusuke Endoh mame@tsg.ne.jp

#3 [ruby-core:50198] Updated by Eric Hodel about 4 years ago

  • % Done changed from 0 to 90

I have updated RDoc to 4.0.

You may need to delete .ext/rdoc as the format of the ri data has changed. While I did my best to support backwards compatibility I may not (yet) have fixed every problem. Please try this before reporting further bugs if documentation generation fails.

I will continue to monitor documentation generation for bugs.

#4 [ruby-core:50202] Updated by Koichi Sasada about 4 years ago

(2012/11/27 13:33), drbrain (Eric Hodel) wrote:

You may need to delete .ext/rdoc as the format of the ri data has changed. While I did my best to support backwards compatibility I may not (yet) have fixed every problem. Please try this before reporting further bugs if documentation generation fails.

I will continue to monitor documentation generation for bugs.

I can't build ruby because of rdoc failure on mswin32.

...

Generating RI format into C:/ko1/src/ruby/mswin32.build/.ext/rdoc...
uh-oh! RDoc had a problem:
Invalid argument - ./C:

run with --debug for full backtrace
NMAKE : fatal error U1077: '.\ruby.exe' : return code '0x1'
Stop.

--
// SASADA Koichi at atdot dot net

#5 [ruby-core:50203] Updated by Luis Lavena about 4 years ago

On Tue, Nov 27, 2012 at 12:57 AM, SASADA Koichi ko1@atdot.net wrote:

(2012/11/27 13:33), drbrain (Eric Hodel) wrote:

You may need to delete .ext/rdoc as the format of the ri data has changed. While I did my best to support backwards compatibility I may not (yet) have fixed every problem. Please try this before reporting further bugs if documentation generation fails.

I will continue to monitor documentation generation for bugs.

I can't build ruby because of rdoc failure on mswin32.

I have a high number of failures on Windows (mingw32) when running
rdoc tests directly from github repository:

https://gist.github.com/4152653

Is 1am here, was going to bed now, I can't check and fix those now, sorry :-(

--
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

#6 [ruby-core:50204] Updated by Eric Hodel about 4 years ago

On Nov 26, 2012, at 10:09 PM, Luis Lavena luislavena@gmail.com wrote:

On Tue, Nov 27, 2012 at 12:57 AM, SASADA Koichi ko1@atdot.net wrote:

(2012/11/27 13:33), drbrain (Eric Hodel) wrote:

You may need to delete .ext/rdoc as the format of the ri data has changed. While I did my best to support backwards compatibility I may not (yet) have fixed every problem. Please try this before reporting further bugs if documentation generation fails.

I will continue to monitor documentation generation for bugs.

I can't build ruby because of rdoc failure on mswin32.

I have added --debug to the make rule to help find such bugs.

I have a high number of failures on Windows (mingw32) when running
rdoc tests directly from github repository:

https://gist.github.com/4152653

Is 1am here, was going to bed now, I can't check and fix those now, sorry :-(

Thanks! I think I can fix most of these even without windows!

#7 [ruby-core:50206] Updated by Eric Hodel about 4 years ago

On Nov 26, 2012, at 10:17 PM, Eric Hodel drbrain@segment7.net wrote:

On Nov 26, 2012, at 10:09 PM, Luis Lavena luislavena@gmail.com wrote:

On Tue, Nov 27, 2012 at 12:57 AM, SASADA Koichi ko1@atdot.net wrote:

I can't build ruby because of rdoc failure on mswin32.

I have added --debug to the make rule to help find such bugs.

I have a high number of failures on Windows (mingw32) when running
rdoc tests directly from github repository:

https://gist.github.com/4152653

Is 1am here, was going to bed now, I can't check and fix those now, sorry :-(

Thanks! I think I can fix most of these even without windows!

Ok, I have fixed all of these except the RDoc::RI::Paths failures. I see why it is happening, so I should be able to fix it shortly.

#8 [ruby-core:50211] Updated by Eric Hodel about 4 years ago

On Nov 26, 2012, at 11:21 PM, Eric Hodel drbrain@segment7.net wrote:

On Nov 26, 2012, at 10:17 PM, Eric Hodel drbrain@segment7.net wrote:

On Nov 26, 2012, at 10:09 PM, Luis Lavena luislavena@gmail.com wrote:

On Tue, Nov 27, 2012 at 12:57 AM, SASADA Koichi ko1@atdot.net wrote:

I can't build ruby because of rdoc failure on mswin32.

I have added --debug to the make rule to help find such bugs.

I have a high number of failures on Windows (mingw32) when running
rdoc tests directly from github repository:

https://gist.github.com/4152653

Is 1am here, was going to bed now, I can't check and fix those now, sorry :-(

Thanks! I think I can fix most of these even without windows!

Ok, I have fixed all of these except the RDoc::RI::Paths failures. I see why it is happening, so I should be able to fix it shortly.

Thanks to Luis and Koichi's help I have fixed the errors and have fixed building documentation outside $(srcdir)

#9 [ruby-core:50418] Updated by Eric Hodel about 4 years ago

  • Category set to lib
  • Status changed from Assigned to Closed

Also available in: Atom PDF