Bug #7534

/(?i:[\W])/ and /(?i:[\w])/ both match "s"

Added by Hiro Asari over 1 year ago. Updated over 1 year ago.

[ruby-core:50685]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0dev (2012-12-08 trunk 38268) [x86_64-darwin12.2.1] Backport:

Description

If you drop any of the 3 conditions - case-insensitivity, character class, or "s" - this bug does not happen.

See https://gist.github.com/4238886


Related issues

Duplicates ruby-trunk - Bug #7533: Oniguruma hates the letter 's' :( Closed 12/08/2012
Duplicates ruby-trunk - Bug #4044: Regex matching errors when using \W character class and /... Feedback 11/11/2010

History

#2 Updated by Charlie Somerville over 1 year ago

Related to #7533

#3 Updated by Heesob Park over 1 year ago

As far as I can remember, this issue is two years old.
Refer to #4044

#4 Updated by Hiro Asari over 1 year ago

Indeed, this is a duplicate of #4044. My apologies. Please close this one. Thank you.

#5 Updated by Vit Ondruch over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF