Project

General

Profile

Bug #7737

problem with generated rbconfig.rb for Haiku

Added by paul0 (Paulo Geyer) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2013-01-23 trunk 38898) [i586-haiku]
Backport:
[ruby-core:51602]

Description

After compiling ruby 2.0.0 for Haiku, I couldn't install gems with native extensions, found something wrong with rbconfig.rb

CONFIG["RPATHFLAG"] = " -Wl,-R%1$-s"

changing that to:
CONFIG["RPATHFLAG"] = ""

made possible to rubygems create native extensions

bug-7737.diff (918 Bytes) bug-7737.diff nobu (Nobuyoshi Nakada), 01/25/2013 03:43 PM
bug-7737.diff (586 Bytes) bug-7737.diff nobu (Nobuyoshi Nakada), 01/28/2013 05:31 PM

Related issues

Has duplicate Ruby trunk - Bug #7736: problem with generated rbconfig.rb for HaikuClosed2013-01-23
Is duplicate of Ruby trunk - Bug #7279: Zlib load error on HP-UXFeedback2012-11-05

History

#1 [ruby-core:51630] Updated by ko1 (Koichi Sasada) over 4 years ago

  • Category set to build
  • Assignee set to nobu (Nobuyoshi Nakada)
  • Target version set to 2.0.0

Nobu, could you check this issue?

#2 [ruby-core:51662] Updated by nobu (Nobuyoshi Nakada) over 4 years ago

Could you try the attached patch?

#3 [ruby-core:51723] Updated by nobu (Nobuyoshi Nakada) over 4 years ago

Seems RPATHFLAG unnecessary for extconf.rb.

Attaching newer patch.

#4 [ruby-core:51810] Updated by paul0 (Paulo Geyer) over 4 years ago

nobu (Nobuyoshi Nakada) wrote:

Seems RPATHFLAG unnecessary for extconf.rb.

Attaching newer patch.

tried again with the latest patch, and updated my local code with the remote repository, now it can't find "complex.o"

here is the make output

linking shared-object io/wait.so
installing default wait libraries
make[2]: Leaving directory /home/code/ruby/ext/io/wait'
make[2]: Entering directory
/home/code/ruby/ext/json'
installing default libraries
make[2]: Leaving directory /home/code/ruby/ext/json'
make[2]: Entering directory
/home/code/ruby/ext/json/generator'
linking shared-object json/ext/generator.so
installing default generator libraries
make[2]: Leaving directory /home/code/ruby/ext/json/generator'
make[2]: Entering directory
/home/code/ruby/ext/json/parser'
linking shared-object json/ext/parser.so
installing default parser libraries
make[2]: Leaving directory /home/code/ruby/ext/json/parser'
make[2]: Entering directory
/home/code/ruby/ext/mathn/complex'
linking shared-object mathn/complex.so
ld: cannot find complex.o: No such file or directory
make[2]: *** [../../../.ext/i586-haiku/mathn/complex.so] Error 1
make[2]: Leaving directory /home/code/ruby/ext/mathn/complex'
make[1]: *** [ext/mathn/complex/all] Error 2
make[1]: Leaving directory
/home/code/ruby'
make: *** [build-ext] Error 2

#5 [ruby-core:51811] Updated by paul0 (Paulo Geyer) over 4 years ago

fixed that, changed to $(srcdir)/complex.o the line where tells where the object to be linked is in the ext/mathn/complex/Makefile

had to do that with ext/mathn/rational/Makefile too

#6 [ruby-core:51812] Updated by paul0 (Paulo Geyer) over 4 years ago

paul0 (Paulo Geyer) wrote:

fixed that, changed to $(srcdir)/complex.o the line where tells where the object to be linked is in the ext/mathn/complex/Makefile

had to do that with ext/mathn/rational/Makefile too

fixed other things, and finished compiling
this patch haven't solved the gem native extension problem, it still tries to use -Wl parameter with ld

#7 [ruby-core:51825] Updated by nobu (Nobuyoshi Nakada) over 4 years ago

paul0 (Paulo Geyer) wrote:

fixed that, changed to $(srcdir)/complex.o the line where tells where the object to be linked is in the ext/mathn/complex/Makefile

$(srcdir)/complex.o?
I have no idea why the object file is prefixed with $(srcdir).
Can't you show that Makefile?

#8 [ruby-core:52486] Updated by mame (Yusuke Endoh) over 4 years ago

Looks similar to #7864. Does r39290 help you?

--
Yusuke Endoh mame@tsg.ne.jp

#9 [ruby-core:54437] Updated by naruse (Yui NARUSE) over 4 years ago

Closed because no feedback.

#10 [ruby-core:54438] Updated by naruse (Yui NARUSE) over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF