Project

General

Profile

Bug #7847

gem release of io-console is broken on Windows

Added by luislavena (Luis Lavena) over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
1.9.x and 2.0.x
Backport:
[ruby-core:52220]

Description

Nobu-san,

Lot of folks are having issues with latest io-console gem that got released:

https://github.com/nobu/io-console/issues/6

https://groups.google.com/d/topic/rubyinstaller/9qbj5HKN7w4/discussion

The code in the GitHub repository is 3 years old, so I can't provide a pull request that patches the behavior.

I'm not sure where the code that is part of the gem is coming from, since io-console compiles without issues as part of Ruby extensions.

I'm opening this here due the lack of feedback on GitHub issues and the raise of more reports about this issue.

Thank you.

Associated revisions

Revision 39268
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: compatibility with 1.9

  • ext/io/console/console.c (rawmode_opt, console_dev): compatibility with ruby 1.9. [Bug #7847]

Revision 39268
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: compatibility with 1.9

  • ext/io/console/console.c (rawmode_opt, console_dev): compatibility with ruby 1.9. [Bug #7847]

Revision 39268
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: compatibility with 1.9

  • ext/io/console/console.c (rawmode_opt, console_dev): compatibility with ruby 1.9. [Bug #7847]

Revision 39268
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: compatibility with 1.9

  • ext/io/console/console.c (rawmode_opt, console_dev): compatibility with ruby 1.9. [Bug #7847]

Revision 39272
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: 0.4.2

  • ext/io/console/io-console.gemspec: bump to 0.4.2. now explicitly requires ruby 1.9.3 or later. [Bug #7847]

Revision 39272
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: 0.4.2

  • ext/io/console/io-console.gemspec: bump to 0.4.2. now explicitly requires ruby 1.9.3 or later. [Bug #7847]

Revision 39272
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: 0.4.2

  • ext/io/console/io-console.gemspec: bump to 0.4.2. now explicitly requires ruby 1.9.3 or later. [Bug #7847]

Revision 39272
Added by nobu (Nobuyoshi Nakada) over 4 years ago

io/console: 0.4.2

  • ext/io/console/io-console.gemspec: bump to 0.4.2. now explicitly requires ruby 1.9.3 or later. [Bug #7847]

History

#1 Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r39268.
Luis, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


io/console: compatibility with 1.9

  • ext/io/console/console.c (rawmode_opt, console_dev): compatibility with ruby 1.9. [Bug #7847]

#2 [ruby-core:52576] Updated by luislavena (Luis Lavena) over 4 years ago

  • Status changed from Closed to Open

Thank you Nobu.

Can you release io-console 0.4.2 to rubygems.org?

That will fix the situation for users running 1.9.3.

Thank you.

#3 Updated by naruse (Yui NARUSE) over 4 years ago

  • Target version changed from 1.9.3 to next minor

#4 [ruby-core:56426] Updated by naruse (Yui NARUSE) about 4 years ago

  • Status changed from Open to Closed

http://rubygems.org/gems/io-console/versions/0.4.2 is released at February 16, 2013.

Also available in: Atom PDF