Bug #8990

please disable *context on hurd

Added by Gabriele Giacone 6 months ago. Updated 6 months ago.

[ruby-core:57685]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0p299 (2013-08-29) [i386-gnu] Backport:1.9.3: UNKNOWN, 2.0.0: DONE

Description

This bug can be reproduced in Ruby 1.8 as well.

Attached patch disables *context use on hurd.
Hurd implementation is not working yet and it's hard estimating whenever it will be.

Thanks.

patch01 (616 Bytes) Gabriele Giacone, 10/06/2013 06:49 AM

Associated revisions

Revision 43193
Added by Motohiro KOSAKI 6 months ago

  • cont.c: disable FIBERUSENATIVE on GNU/Hurd because it doesn't support a combination getcontext() and threads. Patch by Gabriele Giacone (1o5g4r8o@gmail.com). [Bug #8990]

History

#1 Updated by Motohiro KOSAKI 6 months ago

  1. Every workaroud patch should have a comment why it is needed any which version has a problem. Even though prior work don't.
  2. defined(GNU) is unclear and confusable because a lot of people aren't familiar Hurd. So, it should be commented it's for GNU/Hurd.
  3. Now, we have 5th exception (MS-Windows, NetBSD, Solaris, IA64, Hurd). So, it's a good time to move the check to configure.in.

#2 Updated by Yui NARUSE 6 months ago

  • Status changed from Open to Feedback

#3 Updated by Gabriele Giacone 6 months ago

kosaki (Motohiro KOSAKI) wrote:

  1. Every workaroud patch should have a comment why it is needed any which version has a problem. Even though prior work don't.

Comment might be: "GNU/Hurd doesn't fully support {get,set,make,swap}context functions. Disabling their usage till support is implemented. More info at http://darnassus.sceen.net/~hurd-web/open_issues/glibc/#getcontext"
Feel free to rephrase as you prefer.

  1. defined(GNU) is unclear and confusable because a lot of people aren't familiar Hurd. So, it should be commented it's for GNU/Hurd.

It's fine what you did in r43077.

#4 Updated by Motohiro KOSAKI 6 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r43193.
Gabriele, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • cont.c: disable FIBERUSENATIVE on GNU/Hurd because it doesn't support a combination getcontext() and threads. Patch by Gabriele Giacone (1o5g4r8o@gmail.com). [Bug #8990]

#5 Updated by Motohiro KOSAKI 6 months ago

Committed at r43193. Thank you!

#6 Updated by Tomoyuki Chikanaga 6 months ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: UNKNOWN, 2.0.0: DONE

backported to ruby20_0 at r43225.

Also available in: Atom PDF