Project

General

Profile

Bug #9199

win32.h is not installed by '(n)make install)

Added by arton (Akio Tajima) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0p353 (2013-11-22) [i386-mswin32_100]
[ruby-core:58801]

Description

I try to install ruby-2.0.0-p353 (also rubytrunk) using 'nmake install' but ruby/win32.h does not include in include directory.

cause: tool/rbinstall.rb checks that it's required win32.h by 'unless RUBY_PLATFORM =~ /mswin|mingw|bccwin/.
It's ok but current common.mk invokes rbinstall.rb with -r./$(arch)-fake and it only rests 'i386' in RUBY_PLATFORM.

I'm not certain the reason of $(arch)-fake, so don't know how to fix it.


Related issues

Related to Backport21 - Backport #9271: please backport r44307Closed2013-12-212013-12-25

Associated revisions

Revision 44307
Added by usa (Usaku NAKAMURA) over 3 years ago

  • win32/Makefile.sub (fake.rb): fixed wrong RUBY_PLATFORM, to correctly install win32.h. [Bug #9199] reported by arton.

Revision 44307
Added by usa (Usaku NAKAMURA) over 3 years ago

  • win32/Makefile.sub (fake.rb): fixed wrong RUBY_PLATFORM, to correctly install win32.h. [Bug #9199] reported by arton.

Revision 44307
Added by usa (Usaku NAKAMURA) over 3 years ago

  • win32/Makefile.sub (fake.rb): fixed wrong RUBY_PLATFORM, to correctly install win32.h. [Bug #9199] reported by arton.

Revision 44307
Added by usa (Usaku NAKAMURA) over 3 years ago

  • win32/Makefile.sub (fake.rb): fixed wrong RUBY_PLATFORM, to correctly install win32.h. [Bug #9199] reported by arton.

History

#1 [ruby-core:58802] Updated by luislavena (Luis Lavena) over 3 years ago

  • Status changed from Open to Assigned

#2 [ruby-core:58820] Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Assignee changed from nobu (Nobuyoshi Nakada) to Glass_saga (Masaki Matsushita)
  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: REQUIRED

this problem caused by r42862.
Why does INSTRUBY always need to include $(arch)-fake ?
It is only needed when cross compiling and prereq, IMO.

#3 [ruby-core:59238] Updated by usa (Usaku NAKAMURA) over 3 years ago

Note that this problem is not fixed at 2.1.0-rc1, and I think this is a critical showstopper.

#4 Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44307.
Akio, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • win32/Makefile.sub (fake.rb): fixed wrong RUBY_PLATFORM, to correctly install win32.h. [Bug #9199] reported by arton.

#5 [ruby-core:59250] Updated by nagachika (Tomoyuki Chikanaga) over 3 years ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONE

r44307 was backported to ruby_2_0_0 at r44323.

Also available in: Atom PDF