Project

General

Profile

Bug #9289

Segmentation fault - RailsInstaller, RubyInstaller, Ruby.

Added by bob (bob barker) over 5 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
1.9.3p484
Backport:
[ruby-core:59291]

Description

Installed RailsInstaller; Ruby crashes it on post-install config (ssh/git). Confirmed by running ruby with no params and crashes.
Downloaded various versions of Ruby from RubyInstaller project (as 7z's) - latest version to not crash on running ruby.exe was:
ruby-1.9.3-p286-i386-mingw32.7z

moves up past that in version number crash i.e. ruby-1.9.3-p327-i386-mingw32
oddly enough, can run ruby --version on all the later ones without it crashing

--

C:>ruby
ruby: [BUG] Segmentation fault
ruby 1.9.3p484 (2013-11-22) [i386-mingw32]

-- Control frame information -----------------------------------------------
c:0001 p:0000 s:0002 b:0002 l:001a8c d:001a8c TOP

-- C level backtrace information -------------------------------------------
C:\WINDOWS\system32\ntdll.dll(KiFastSystemCallRet+0x0) [0x7c90e514]
C:\WINDOWS\system32\kernel32.dll(WaitForSingleObject+0x12) [0x7c802542]
C:\RailsInstaller\Ruby1.9.3\bin\msvcrt-ruby191.dll(rb_vm_bugreport+0xf9) [0x62e5cf51]
C:\RailsInstaller\Ruby1.9.3\bin\msvcrt-ruby191.dll(rb_name_err_mesg_new+0x17a) [0x62d3a862]
C:\RailsInstaller\Ruby1.9.3\bin\msvcrt-ruby191.dll(rb_bug+0x2f) [0x62d3b53f]
C:\RailsInstaller\Ruby1.9.3\bin\msvcrt-ruby191.dll(rb_check_safe_str+0x194) [0x62def0bc]
[0x004011e6]
C:\WINDOWS\system32\kernel32.dll(UnhandledExceptionFilter+0x1c7) [0x7c864209]

-- Other runtime information -----------------------------------------------

  • Loaded script: ruby

  • Loaded features:

    0 enumerator.so

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

--

System: winxp sp3 - fully patched.

Installer was:
railsinstaller-2.2.2.exe

from:
http://rubyinstaller.org/downloads/archives/

last version to work is:
Ruby 1.9.3-p286

breaks on move up to:
Ruby 1.9.3-p327

History

Updated by luislavena (Luis Lavena) over 5 years ago

  • Status changed from Open to Feedback

Hello,

This type of crashing sometimes is associated with other tools that is affecting loading of DLLs.

Can you verify if you have installed ansicon or FRAPS? Also, can you tell us which Antivirus software you have installed?

Thank you.

Updated by bob (bob barker) over 5 years ago

Neither Ansicon or FRAPS is installed. I am using the free edition of ZoneAlarm Firewall+Antivirus. To get the rails-installer to finish its config work, I replaced the p484 version with p286 version after it installed but before I hit next for it to complete its ssh/git configs. Latest version of JRuby is also installed in case it makes a difference.

Updated by phasis68 (Heesob Park) over 5 years ago

This issue is an unresolved issue with a long history.

https://github.com/oneclick/rubyinstaller/issues/144

http://www.ssknet.org/sasaki.ssknet.org/?p=960

I guess it is related with the encoding of file system according to the ChangeLog of 1.9.3-p327.

How can I reproduce your issue?

Can you show the environment variables like PATH, HOMEPATH, RUBYOPT, RUBYLIB, TEMP etc which might be contain non-ascii value?

Updated by bob (bob barker) over 5 years ago

You can't ;) I can - what sort of trace would you need to tell exactly what its crapping out on (i.e. debugging the startup of the interpreter?); Would building the files rather than using the installer and comparing (i.e. checking of the locally-compiled version) crashes help? Sort of determining if the problem is in the source versus the distro (compilation params)? I am at your service.

Updated by phasis68 (Heesob Park) over 5 years ago

The gdb(the GNU debugger included in DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe) trace information would be helpful.

Refer to http://bugs.ruby-lang.org/issues/5375 for how to produce it.

#6

Updated by jeremyevans0 (Jeremy Evans) 2 months ago

  • Backport deleted (1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN)
  • Status changed from Feedback to Closed

Also available in: Atom PDF