Bug #9348

--with-tcllib and --with-tklib configure options not working correctly

Added by Jeremy Evans over 1 year ago. Updated about 1 year ago.

[ruby-core:59483]
Status:Closed
Priority:Normal
Assignee:Hidetoshi Nagai
ruby -v:ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-openbsd] Backport:1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

Description

When using the --with-tcllib=tcl85 -with-tklib=tk85 configure options, ruby still tries to use -ltcl -ltk as linker options for the tk extension (instead of -ltcl85 -ltk85), which causes the tk extension not to build. This is due to a bug in the tk extconf.rb file, which should be fixed by the attached patch.

patch-ext_tk_extconf_rb (768 Bytes) Jeremy Evans, 01/03/2014 08:37 AM

Associated revisions

Revision 44574
Added by Hidetoshi Nagai over 1 year ago

  • ext/tk/extconf.rb: --with-tcllib and --with-tklib configure options don't work correctly. Patch by jeremyevans0 (Jeremy Evans). [Bug #9348]

Revision 44574
Added by Hidetoshi Nagai over 1 year ago

  • ext/tk/extconf.rb: --with-tcllib and --with-tklib configure options don't work correctly. Patch by jeremyevans0 (Jeremy Evans). [Bug #9348]

History

#1 Updated by Hiroshi SHIBATA over 1 year ago

  • Assignee set to Hidetoshi Nagai

#2 Updated by Tomoyuki Chikanaga over 1 year ago

fixed by r44574.

#3 Updated by Tomoyuki Chikanaga over 1 year ago

  • Category set to ext
  • Status changed from Open to Closed

#4 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

Also available in: Atom PDF