Project

General

Profile

Bug #9370

Parse error when using XMLTreeParser in xmlrpc

Added by herwinw (Herwin Quarantainenet) over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:59590]

Description

When using XMLTreeParser as the parser in the XMLRPC libraries, a simple methodCall parse with a parameter results in an assertion error. A script to test this is attached.

parser.rb (290 Bytes) parser.rb test file for behaviour of parser herwinw (Herwin Quarantainenet), 01/06/2014 08:38 PM

Related issues

Related to Ruby trunk - Bug #9369: Using XMLScanStreamParser in xmlrpc/parser may result in parse errorsClosed

Associated revisions

Revision d8e3a924
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

  • lib/xmlrpc.rb: Removed broken parser named XMLTreeParser. Required gem of its parser didn't compile on newer Ruby versions. [fix GH-1271][Bug #9370]
  • lib/xmlrpc/config.rb: ditto.
  • lib/xmlrpc/parser.rb: ditto.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53980 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 53980
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

  • lib/xmlrpc.rb: Removed broken parser named XMLTreeParser. Required gem of its parser didn't compile on newer Ruby versions. [fix GH-1271][Bug #9370]
  • lib/xmlrpc/config.rb: ditto.
  • lib/xmlrpc/parser.rb: ditto.

Revision 53980
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

  • lib/xmlrpc.rb: Removed broken parser named XMLTreeParser. Required gem of its parser didn't compile on newer Ruby versions. [fix GH-1271][Bug #9370]
  • lib/xmlrpc/config.rb: ditto.
  • lib/xmlrpc/parser.rb: ditto.

Revision 53980
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

  • lib/xmlrpc.rb: Removed broken parser named XMLTreeParser. Required gem of its parser didn't compile on newer Ruby versions. [fix GH-1271][Bug #9370]
  • lib/xmlrpc/config.rb: ditto.
  • lib/xmlrpc/parser.rb: ditto.

History

#1 Updated by hsbt (Hiroshi SHIBATA) about 2 years ago

  • Status changed from Open to Closed

Applied in changeset r53980.


  • lib/xmlrpc.rb: Removed broken parser named XMLTreeParser. Required gem of its parser didn't compile on newer Ruby versions. [fix GH-1271][Bug #9370]
  • lib/xmlrpc/config.rb: ditto.
  • lib/xmlrpc/parser.rb: ditto.

#2 Updated by usa (Usaku NAKAMURA) about 2 years ago

  • Related to Bug #9369: Using XMLScanStreamParser in xmlrpc/parser may result in parse errors added

Also available in: Atom PDF