Bug #9476

RDoc generation failure on Windows

Added by Heesob Park almost 2 years ago. Updated almost 2 years ago.

ruby -v:ruby 2.2.0dev (2014-02-03 trunk 44798) [x64-mswin64_120] Backport:1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED


The revision r44796 introduced rdoc generation failure.

Generating RDoc documentation
C:/work/ruby-2.2.0-r44798/lib/monitor.rb:9:in require': cannot load such file -- thread (LoadError)
from C:/work/ruby-2.2.0-r44798/lib/monitor.rb:9:in
from C:/work/ruby-2.2.0-r44798/lib/rubygems/core_ext/kernel_require.rb:7:in require'
from C:/work/ruby-2.2.0-r44798/lib/rubygems/core_ext/kernel_require.rb:7:in
from C:/work/ruby-2.2.0-r44798/lib/rubygems.rb:1214:in require'
from C:/work/ruby-2.2.0-r44798/lib/rubygems.rb:1214:in
from internal:gem_prelude:1:in require'
from <internal:gem_prelude>:1:in
NMAKE : fatal error U1077: '.\ruby.exe' : return code '0x1'

Also found on rubyci.org


#1 Updated by Hiroshi SHIBATA almost 2 years ago

  • Status changed from Open to Feedback

It is still happened in trunk? it is fixed by r44801, r44802 and r44807 probably.

#2 Updated by Heesob Park almost 2 years ago

This issue was solved with r44801.

#3 Updated by Zachary Scott almost 2 years ago

  • Status changed from Feedback to Closed

#4 Updated by Usaku NAKAMURA almost 2 years ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED

Also available in: Atom PDF