Feature #9864

Rename 'optparse' to 'optionparser', or the main class OptionParser to OptParse

Added by Robert A. Heiler 10 months ago. Updated 10 months ago.

[ruby-core:62750]
Status:Closed
Priority:Low
Assignee:-

Description

Hello.

I don't like the inconsistency in the naming of optparse and the class that
we are supposed to use itself.

I think it would be better to do:

require 'optparse'
OptParse.new

or

require 'optionparser'
OptionParser.new

Associated revisions

Revision 46126
Added by Nobuyoshi Nakada 10 months ago

lib/optionparser.rb

  • lib/optionparser.rb, lib/optparse.rb (OptParse): aliases. [Feature #9864]

Revision 46126
Added by Nobuyoshi Nakada 10 months ago

lib/optionparser.rb

  • lib/optionparser.rb, lib/optparse.rb (OptParse): aliases. [Feature #9864]

History

#1 Updated by Robert A. Heiler 10 months ago

Currently, we have to do this:

require 'optparse'
OptionParser.new

#2 Updated by Nobuyoshi Nakada 10 months ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r46126.


lib/optionparser.rb

  • lib/optionparser.rb, lib/optparse.rb (OptParse): aliases. [Feature #9864]

Also available in: Atom PDF