Project

General

Profile

Actions

Bug #10698

closed

Time#local behaves differently during clock change

Added by boris (Boris Ruf) almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]
[ruby-core:67345]

Description

This is probably not a bug but since it changes previous behavior it should be noted somewhere.

Ruby 2.1.5:

>> ENV['TZ'] = 'Europe/Berlin'
=> "Europe/Berlin"
>> Time.local(2011,10,30,2,0,0).zone
=> "CET"

Ruby 2.2.0:

>> ENV['TZ'] = 'Europe/Berlin'
=> "Europe/Berlin"
>> Time.local(2011,10,30,2,0,0).zone
=> "CEST"

So in older Ruby versions the object represents the time after the clock change (within the extra hour), while in Ruby 2.2.0 it represents the time before time is set back.

Actions

Also available in: Atom PDF