Project

General

Profile

Bug #10717

TestGemExtCmakeBuilder#test_self_build fails on RHEL 6/CentOS 6

Added by vo.x (Vit Ondruch) over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux-gnu]
[ruby-core:67436]

Description

$ rpm -q cmake
cmake-2.6.4-5.el6.x86_64

$ make test-all TESTS=-n\ TestGemExtCmakeBuilder#test_self_build

<snip>

./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems "./test/runner.rb" --ruby="./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems"  -n TestGemExtCmakeBuilder#test_self_build
Run options: "--ruby=./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems" -n TestGemExtCmakeBuilder#test_self_build

# Running tests:

[1/0] TestGemExtCmakeBuilder#test_self_build = 0.29 s
  1) Error:
TestGemExtCmakeBuilder#test_self_build:
Gem::InstallError: cmake failed, exit code 1
    /builddir/build/BUILD/ruby-2.2.0/lib/rubygems/ext/builder.rb:89:in `run'
    /builddir/build/BUILD/ruby-2.2.0/lib/rubygems/ext/cmake_builder.rb:9:in `build'
    /builddir/build/BUILD/ruby-2.2.0/test/rubygems/test_gem_ext_cmake_builder.rb:33:in `block in test_self_build'
    /builddir/build/BUILD/ruby-2.2.0/test/rubygems/test_gem_ext_cmake_builder.rb:32:in `chdir'
    /builddir/build/BUILD/ruby-2.2.0/test/rubygems/test_gem_ext_cmake_builder.rb:32:in `test_self_build'

Closed file descriptor: TestGemExtCmakeBuilder#test_self_build: 7
Finished tests in 7.221309s, 0.1385 tests/s, 0.0000 assertions/s.
1 tests, 0 assertions, 0 failures, 1 errors, 0 skips

ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux-gnu]
make: *** [yes-test-all] Error 1

This PR fixes the issue in RubyGems: https://github.com/rubygems/rubygems/pull/1124

Associated revisions

Revision 897693b4
Added by naruse (Yui NARUSE) about 4 years ago

Partially merge revision 49195: [Bug #10717]

Support cmake 2.6 which is used by RHEL6/ CentOS 6
https://github.com/rubygems/rubygems/pull/1124

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@49703 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49703
Added by naruse (Yui NARUSE) about 4 years ago

Partially merge revision 49195: [Bug #10717]

Support cmake 2.6 which is used by RHEL6/ CentOS 6
https://github.com/rubygems/rubygems/pull/1124

Revision e8dc702f
Added by usa (Usaku NAKAMURA) almost 4 years ago

Partially merge revision 49195: [Bug #10717]

Support cmake 2.6 which is used by RHEL6/ CentOS 6
https://github.com/rubygems/rubygems/pull/1124

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@50668 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50668
Added by usa (Usaku NAKAMURA) almost 4 years ago

Partially merge revision 49195: [Bug #10717]

Support cmake 2.6 which is used by RHEL6/ CentOS 6
https://github.com/rubygems/rubygems/pull/1124

History

Updated by vo.x (Vit Ondruch) over 4 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: UNKNOWN, 2.1: REQUIRED, 2.2: REQUIRED

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Status changed from Open to Third Party's Issue

Updated by naruse (Yui NARUSE) about 4 years ago

  • Status changed from Third Party's Issue to Closed

Updated by naruse (Yui NARUSE) about 4 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: UNKNOWN, 2.1: REQUIRED, 2.2: DONE

ruby_2_2 r49703 partially merged revision(s) 49195.

Updated by usa (Usaku NAKAMURA) almost 4 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: REQUIRED, 2.2: DONE to 2.0.0: UNKNOWN, 2.1: DONE, 2.2: DONE

At r50668, r49703 is partially merged into ruby_2_1.

Also available in: Atom PDF