Project

General

Profile

Bug #11162

Update documentation for CMath library

Added by davydov_anton (Anton Davydov) almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:<unknown>]

Description

Hello!

I updated description and 'Usage' part for CMath library, added 'Brief overview of complex numbers' part and added two books about complex numbers. Also I added examples for each library method.

P.S.: this is my first redmine issue with patch, therefore if I did something wrong, please tell me about it.

Thanks.

0001-Update-documentation-for-CMath-library.patch View (7.35 KB) davydov_anton (Anton Davydov), 05/19/2015 11:15 PM

Associated revisions

Revision 50793
Added by gogotanaka (Kazuki Tanaka) almost 2 years ago

  • lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162] Patch provided by @davydovanton

Revision 50793
Added by gogotanaka (Kazuki Tanaka) almost 2 years ago

  • lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162] Patch provided by @davydovanton

Revision 50793
Added by gogotanaka (Kazuki Tanaka) almost 2 years ago

  • lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162] Patch provided by @davydovanton

Revision 51121
Added by usa (Usaku NAKAMURA) almost 2 years ago

merge revision(s) 50793,51120: [Backport #11162]

* lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162]
Patch provided by @davydovanton

Revision 51132
Added by nagachika (Tomoyuki Chikanaga) almost 2 years ago

merge revision(s) 50793,51120: [Backport #11162]

* lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162]
Patch provided by @davydovanton

History

#1 Updated by gogotanaka (Kazuki Tanaka) almost 2 years ago

  • Status changed from Open to Closed

Applied in changeset r50793.


  • lib/cmath.rb: [DOC] Add docs [ci skip][Fix GH-909][Bug #11162] Patch provided by @davydovanton

#2 [ruby-core:69795] Updated by usa (Usaku NAKAMURA) almost 2 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED

#3 [ruby-core:69854] Updated by usa (Usaku NAKAMURA) almost 2 years ago

  • Backport changed from 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED

ruby_2_1 r51121 merged revision(s) 50793,51120.

#4 [ruby-core:69863] Updated by nagachika (Tomoyuki Chikanaga) almost 2 years ago

  • Backport changed from 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: DONE, 2.2: DONE

Backported into ruby_2_2 branch at r51132.

Also available in: Atom PDF