Bug #12614

Segmentation Fault on Ruby 2.3.1

Added by mwear (Matthew Wear) almost 4 years ago. Updated almost 4 years ago.

Target version:
ruby -v:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]



We have an extensive test matrix that tests many versions of Rails over many versions of Ruby. We notice frequent segfaults when running our Rails 3.1 suite with Ruby 2.3.1p112. We run the same suite with Ruby 1.8 - Ruby 2.2 without issues. It appears that our test suite is exposing a subtle bug in Ruby that I suspect that it is related to garbage collection. The segfault does not occur everytime the test suite runs, but if I run the suite in a bash for loop for 100 iterations I usually see 5-10 segfaults. If I turn off garbage collection during the test cases the segfault does not occur over 100 iterations of the test suite.

To Reproduce

I tried, but was unable to come up with a minimal reproduction case. Our code and test suite are publically available and I'll list the steps you can follow to reproduce the issue with some additional setup.

  1. Clone the newrelic rpm github repo from:
  2. git checkout
  3. bundle install
  4. run the test suite a single time (you probably won't see a segfault): bundle exec rake test:multiverse[rails,env=6]
  5. run the test suite in a bash for loop for 100 iterations: for i in `seq 1 100`; do bundle exec rake test:multiverse[rails,env=6]; done

Segfault Output


Possibly Related:


ruby_2_3_segfault.txt (160 KB) ruby_2_3_segfault.txt mwear (Matthew Wear), 07/22/2016 11:38 PM
segv_without_newrelic.rb (518 Bytes) segv_without_newrelic.rb wanabe (_ wanabe), 08/14/2016 06:01 AM
small_test_newrelic_rpm.patch (59.4 KB) small_test_newrelic_rpm.patch wanabe (_ wanabe), 08/14/2016 06:01 AM

Related issues

Has duplicate Ruby master - Bug #12917: Segfault in list_ids_bsearchClosedActions

Also available in: Atom PDF