Project

General

Profile

Actions

Bug #1335

closed

RubyGems 1.3.1 gem method will load all gems beginning with the given name

Added by postmodern (Hal Brodigan) about 13 years ago. Updated about 11 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]
Backport:
[ruby-core:23074]

Description

=begin
I noticed a strange behaviour while testing my libraries with Ruby 1.9.1-p0. I successfully installed ronin version 0.2.2 and ronin-scanners version 0.1.3 with Ruby 1.9.1-p0. When I attempted to load the ronin RubyGem using "gem 'ronin'", I noticed that ronin-scanners 0.1.3 was also loaded into $LOAD_PATH. Since lib/ directories with similar layouts were included into the $LOAD_PATH, this caused various loading issues.

Note: ronin-scanners version 0.1.3 depends on ronin >= 0.2.1, but ronin-scanners is not required by ronin and should not need to be loaded by RubyGems. This behaviour could not be reproduced with Ruby 1.8.6, so I'm left to believe this is a Ruby 1.9.x specific issue.
=end

Actions #1

Updated by zenspider (Ryan Davis) about 13 years ago

=begin

On Mar 30, 2009, at 22:20 , Hal Brodigan wrote:

I noticed a strange behaviour while testing my libraries with Ruby
1.9.1-p0. I successfully installed ronin version 0.2.2 and ronin-
scanners version 0.1.3 with Ruby 1.9.1-p0. When I attempted to load
the ronin RubyGem using "gem 'ronin'", I noticed that ronin-scanners
0.1.3 was also loaded into $LOAD_PATH. Since lib/ directories with
similar layouts were included into the $LOAD_PATH, this caused
various loading issues.

If I understand you correctly, it isn't the gem command, it is ruby
1.9 in general. Look at your $: before calling #gem at all. This is
intentional behavior.

504 % ~/.multiruby/install/1.9.1-p0/bin/gem list

*** LOCAL GEMS ***

hoe (1.11.0)
rake (0.8.4)
rubyforge (1.0.3)
505 % ~/.multiruby/install/1.9.1-p0/bin/irb

$:
=> ["/Users/ryan/.multiruby/install/1.9.1-p0/lib/ruby/gems/1.9.1/gems/
hoe-1.11.0/bin", "/Users/ryan/.multiruby/install/1.9.1-p0/lib/ruby/
gems/1.9.1/gems/hoe-1.11.0/lib", "/Users/ryan/.multiruby/install/1.9.1-
p0/lib/ruby/gems/1.9.1/gems/rake-0.8.4/bin", "/Users/ryan/.multiruby/
install/1.9.1-p0/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib", "/Users/
ryan/.multiruby/install/1.9.1-p0/lib/ruby/gems/1.9.1/gems/
rubyforge-1.0.3/bin", "/Users/ryan/.multiruby/install/1.9.1-p0/lib/
ruby/gems/1.9.1/gems/rubyforge-1.0.3/lib", ...]

=end

Actions #2

Updated by yugui (Yuki Sonoda) almost 13 years ago

  • Assignee set to matz (Yukihiro Matsumoto)
  • Target version set to 1.9.2

=begin

=end

Actions #3

Updated by naruse (Yui NARUSE) over 12 years ago

  • Status changed from Open to Rejected

=begin

=end

Actions

Also available in: Atom PDF