Project

General

Profile

Actions

Bug #13831

closed

error when try to install

Added by khaledal (khaled alajmi) almost 5 years ago. Updated almost 5 years ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.1p111 (2017-03-22 revision 58053) [x64-mingw32]
[ruby-core:82429]

Description

ruby 2.4.1p111 (2017-03-22 revision 58053) [x64-mingw32]

C:\Users\K>gem install sass
C:/Ruby24-x64/lib/ruby/2.4.0/win32/registry.rb:72:in find': unknown encoding name - CP720 (ArgumentError) from C:/Ruby24-x64/lib/ruby/2.4.0/win32/registry.rb:72:in module:Win32'
from C:/Ruby24-x64/lib/ruby/2.4.0/win32/registry.rb:4:in <top (required)>' from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/msys2_installation.rb:46:in require'
from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/msys2_installation.rb:46:in iterate_msys_paths' from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/msys2_installation.rb:69:in msys_path'
from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/msys2_installation.rb:82:in mingw_bin_path' from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/msys2_installation.rb:92:in enable_dll_search_paths'
from C:/Ruby24-x64/lib/ruby/site_ruby/2.4.0/ruby_installer/runtime/singleton.rb:27:in enable_dll_search_paths' from C:/Ruby24-x64/lib/ruby/2.4.0/rubygems/defaults/operating_system.rb:3:in <top (required)>'
from C:/Ruby24-x64/lib/ruby/2.4.0/rubygems.rb:1345:in require' from C:/Ruby24-x64/lib/ruby/2.4.0/rubygems.rb:1345:in <top (required)>'
from internal:gem_prelude:4:in require' from <internal:gem_prelude>:4:in internal:gem_prelude'

C:\Users\K>

Updated by MSP-Greg (Greg L) almost 5 years ago

I'm not that familiar with encoding issues, but I believe CP720 is an older code page. IF you enter cp 1252 in the console, then gem install sass, does the gem install?

Regardless, given the nature of your question, the best place to report your issue (MinGW build, Ruby 2.4) is https://github.com/oneclick/rubyinstaller2/issues

Updated by duerst (Martin Dürst) almost 5 years ago

MSP-Greg (Greg L) wrote:

I'm not that familiar with encoding issues, but I believe CP720 is an older code page.

Yes indeed. CP720 is the DOS encoding for Arabic.

IF you enter cp 1252 in the console,

This should be chcp 1256. The command is "change code page" (chcp). The Windows encoding for Arabic is Windows-1256. Of course, chcp 1252 may also work, but that would be for Western European languages.

Regardless, given the nature of your question, the best place to report your issue (MinGW build, Ruby 2.4) is https://github.com/oneclick/rubyinstaller2/issues

Definitely.

Updated by hsbt (Hiroshi SHIBATA) almost 5 years ago

  • Status changed from Open to Third Party's Issue

I couldn't reproduce this.

C:\Users\hsbt>gem i sass
Fetching: sass-listen-4.0.0.gem (100%)
Successfully installed sass-listen-4.0.0
Fetching: sass-3.5.1.gem (100%)
Successfully installed sass-3.5.1
Parsing documentation for sass-listen-4.0.0
Installing ri documentation for sass-listen-4.0.0
Parsing documentation for sass-3.5.1
Installing ri documentation for sass-3.5.1
Done installing documentation for sass-listen, sass after 14 seconds
2 gems installed

C:\Users\hsbt>

Please report to packager's tracker.

Actions

Also available in: Atom PDF