Project

General

Profile

Bug #14106

[BUG] Segmentation fault

Added by Gillis (Giacomo Ciampoli) almost 2 years ago. Updated 24 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.4.2p198
[ruby-core:83764]

Description

hi,
when i try to compile a sass file i get this error:

C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/sass-3.5.3/lib/sass/util.rb:637: [BUG] Segmentation fault
ruby 2.4.2p198 (2017-09-14 revision 59899) [x64-mingw32]

this is the full log:

(snip)

i've tried with different version of ruby and sass but didnt solve the issue


Files

bug-14106.log (22.1 KB) bug-14106.log nobu (Nobuyoshi Nakada), 11/15/2017 12:22 AM

History

Updated by shevegen (Robert A. Heiler) almost 2 years ago

Isn't this some problem in the sass gem? Default ruby works fine on
your system, right? So only sass should trigger your problem.

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_read_reparse_point+0x111) [0x0000000067b11261]
C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_reparse_symlink_p+0x37) [0x0000000067b11377]

It seems [Bug #14047].
Are you using OneDrive?

Updated by Gillis (Giacomo Ciampoli) almost 2 years ago

shevegen (Robert A. Heiler) wrote:

Isn't this some problem in the sass gem? Default ruby works fine on
your system, right? So only sass should trigger your problem.

i used ruby only for sass, i wrote on sass community on github but the told me that is a ruby problem

Updated by Gillis (Giacomo Ciampoli) almost 2 years ago

nobu (Nobuyoshi Nakada) wrote:

C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_read_reparse_point+0x111) [0x0000000067b11261]
C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_reparse_symlink_p+0x37) [0x0000000067b11377]

It seems [Bug #14047].
Are you using OneDrive?

Yes i'm using it on one drive

Updated by Gillis (Giacomo Ciampoli) almost 2 years ago

nobu (Nobuyoshi Nakada) wrote:

C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_read_reparse_point+0x111) [0x0000000067b11261]
C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_reparse_symlink_p+0x37) [0x0000000067b11377]

It seems [Bug #14047].
Are you using OneDrive?

Yes i'm using it on one drive, but the error appears even when i am not in onedrive

Gillis (Giacomo Ciampoli) wrote:

nobu (Nobuyoshi Nakada) wrote:

C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_read_reparse_point+0x111) [0x0000000067b11261]
C:\Ruby24-x64\bin\x64-msvcrt-ruby240.dll(rb_w32_reparse_symlink_p+0x37) [0x0000000067b11377]

It seems [Bug #14047].
Are you using OneDrive?

Yes i'm using it on one drive

Updated by duerst (Martin Dürst) almost 2 years ago

Gillis (Giacomo Ciampoli) wrote:

i used ruby only for sass, i wrote on sass community on github but the told me that is a ruby problem

Can you give a pointer to that discussion?

Updated by MSP-Greg (Greg L) almost 2 years ago

duerst (Martin Dürst) wrote:

Can you give a pointer to that discussion?

https://github.com/sass/sass/issues/2398

Response was:

Segmentation faults are usually caused by the underlying Ruby implementation. In this case, the error is on line 637 of util.rb, which suggests that there's a bug somewhere in the Pathname#realpath function. I suggest reporting this against Ruby's bug tracker.

#8

Updated by jeremyevans0 (Jeremy Evans) 24 days ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF