Project

General

Profile

Bug #14219

package size of Ruby 2.5 is larger than 2.4

Added by hsbt (Hiroshi SHIBATA) over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Target version:
-
[ruby-core:84396]

Description

A package of Ruby 2.5 was increased file size (about 15MB) from Ruby 2.4.

  • ruby-2.4.3.tar.xz: 9.6M
  • ruby-2.5.0-rc1.tar.xz: 25M

It was caused by spec directory.

~/D/ruby-2.4.3 > du -md 1 | sort -rn | head 
79  .
26  ./enc
14  ./ext
12  ./test
7   ./lib
7   ./doc
3   ./gems
2   ./sample
1   ./win32
1   ./tool

~/D/ruby-2.5.0-rc1 > du -md 1 | sort -rn | head 
121 .
40  ./spec
26  ./enc
14  ./ext
12  ./test
9   ./lib
7   ./doc
3   ./gems
2   ./sample
1   ./win32

After releasing 2.5, I (and eregon?) try to reduce it size or remove them from tar package.


Related issues

Related to Ruby master - Feature #12733: Bundle bundler to ruby coreClosedActions

Associated revisions

Revision e6bf368c
Added by hsbt (Hiroshi SHIBATA) 11 months ago

Removed VCR cassettes files for reducing package size.

[Bug #14219]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65583 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 65583
Added by hsbt (Hiroshi SHIBATA) 11 months ago

Removed VCR cassettes files for reducing package size.

[Bug #14219]

Revision 65583
Added by hsbt (Hiroshi SHIBATA) 11 months ago

Removed VCR cassettes files for reducing package size.

[Bug #14219]

History

Updated by normalperson (Eric Wong) over 1 year ago

hsbt@ruby-lang.org wrote:

Bug #14219: package size of Ruby 2.5 is larger than 2.4
https://bugs.ruby-lang.org/issues/14219

  • ruby-2.4.3.tar.xz: 9.6M
  • ruby-2.5.0-rc1.tar.xz: 25M

It was caused by spec directory.

There's also a lot of bundler vcr data which is already
gz compressed, so not recompressible with xz.

spec/rubyspec/ still exists in SVN and it looks like there's a
lot of empty directories underneath. "git svn" ignores
empty directories, but I guess the tarball is created from SVN.
We can remove those empty trees ASAP and save our users' inodes.

#2

Updated by naruse (Yui NARUSE) over 1 year ago

  • Target version deleted (2.6)

Updated by Eregon (Benoit Daloze) over 1 year ago

Could someone remove spec/rubyspec in SVN? (it's still present in the 2.5.0 tarball)
I did a "git mv" if I recall correctly, but it seems git-svn did not handle this case correctly.

I think it makes sense to keep spec/mspec and spec/ruby, just like we keep test/, if one can run them from the tarball (make test-spec works).

ruby-2.5.0.tar.xz is 11.3 MB so that seems reasonable.

Updated by normalperson (Eric Wong) over 1 year ago

eregontp@gmail.com wrote:

Could someone remove spec/rubyspec in SVN? (it's still present in the 2.5.0 tarball)

Done in r61506

I did a "git mv" if I recall correctly, but it seems git-svn did not handle this case correctly.

Sorry for the confusion, git itself doesn't detect directory renames, yet,
so git svn can't handle it, yet... It's being worked on for git proper,
so git-svn might be able to do it one day, too:

https://public-inbox.org/git/20171129014237.32570-1-newren@gmail.com/

#5

Updated by hsbt (Hiroshi SHIBATA) over 1 year ago

Updated by hsbt (Hiroshi SHIBATA) over 1 year ago

  • Status changed from Assigned to Rejected

I postpone merging bundler into Ruby core. I will close this by stating it again.

Also available in: Atom PDF