Project

General

Profile

Actions

Bug #14889

closed

TracePoint for :line never seems to trigger on argument list. Maybe by design?

Added by ioquatix (Samuel Williams) about 3 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:87729]

Description

I have the following code.

  30  1|        def print_summary(
  31  0|            output = $stdout
  32   |        )

In the margin is the line number followed by the number of hits according to :line trace point.

I feel like line 31 should also trigger a line trace point. It's an argument, but it must be executed.

Maybe a different trace point? :argument?


Related issues

Related to Ruby master - Bug #15634: TracePoint seems to be skipping some methods.ClosedActions
Actions

Also available in: Atom PDF