Project

General

Profile

Feature #15341

Provide emoji version as RbConfig::CONFIG['UNICODE_EMOJI_VERSION']

Added by duerst (Martin Dürst) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:90068]

Description

The Emoji version is different from the Unicode version. Currently, the Unicode version is accessible from RbConfig::CONFIG['UNICODE_VERSION'], but it's not possible to get the Emoji version.

I need the Emoji version for testing, so it would be good to make it available as RbConfig::CONFIG['EMOJI_VERSION'] or RbConfig::CONFIG['UNICODE_EMOJI_VERSION'].

Background: Currently, the Unicode version is 10.0.0, the Emoji version is 5.0. For Ruby 2.6, the Unicode version will be 11.0.0, the Emoji version will be 11.0. The Unicode Consortium expects to keep the versions parallel (but not the same) going forward.

Matz, can you please approve or reject this request? I'll work on implementing it, or ask Nobu if I need help.


Related issues

Related to CommonRuby - Feature #12460: Provide Unicode Version information in a better location that UnicodeNormalize::UNICODE_VERSIONClosednobu (Nobuyoshi Nakada)Actions
Blocks Ruby master - Feature #15182: Update extended grapheme cluster implementation for Unicode 11Closedduerst (Martin Dürst)Actions
#1

Updated by duerst (Martin Dürst) over 1 year ago

  • Related to Feature #12546: Remove UnicodeNormalize::UNICODE_VERSION added
#2

Updated by duerst (Martin Dürst) over 1 year ago

  • Related to deleted (Feature #12546: Remove UnicodeNormalize::UNICODE_VERSION)
#3

Updated by duerst (Martin Dürst) over 1 year ago

  • Related to Feature #12460: Provide Unicode Version information in a better location that UnicodeNormalize::UNICODE_VERSION added
#4

Updated by duerst (Martin Dürst) over 1 year ago

  • Blocks Feature #15182: Update extended grapheme cluster implementation for Unicode 11 added

Updated by shevegen (Robert A. Heiler) over 1 year ago

As I assume matz is quite busy right now, perhaps it should/could be added to the
upcoming developer meeting at:

https://bugs.ruby-lang.org/issues/15342

Now that the emoji (emo?) zombies wrestling with genies and faeries has been integrated
( https://git.ruby-lang.org/ruby.git/commit/?id=a96a594f9978b28d2d374f4a0fc15f5a2224df9b ).

#6

Updated by nobu (Nobuyoshi Nakada) over 1 year ago

  • Status changed from Open to Closed

Applied in changeset trunk|r66270.


Add UNICODE_EMOJI_VERSION to RbConfig [Feature #15341]

Also available in: Atom PDF