Project

General

Profile

Actions

Bug #1541

closed

mingw ssl: Errno::ENOTSOCK: An operation was attempted on something that is not a socket.

Added by rogerdpack (Roger Pack) about 13 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2dev (2009-05-25 trunk 23567) [i386-mingw32]
Backport:
[ruby-core:23639]

Description

=begin
If you delete test_io.rb and test_exception.rb and re-run make test-all for mingw, it completes!
Yea!

Here are a few bug reports from said run.
mingw32, gcc 3.4.5, TRUNK.

overall result: 6050 tests, 2510241 assertions, 40 failures, 89 errors, 7 skips

the first 9 look related:

  1. Error:
    test_client_auth(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  2. Error:
    test_client_session(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  3. Error:
    test_connect_and_close(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  4. Error:
    test_parallel(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  5. Error:
    test_post_connection_check(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  6. Error:
    test_read_and_write(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  7. Error:
    test_server_session(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  8. Error:
    test_ssl_read_nonblock(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

  9. Error:
    test_starttls(OpenSSL::TestSSL):
    Errno::ENOTSOCK: An operation was attempted on something that is not a socket.
    c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept' c:/dev/downloads/ruby_trunk/.ext/common/openssl/ssl-internal.rb:160:in accept'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:79:in block in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in loop'
    c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:76:in server_loop' c:/dev/downloads/ruby_trunk/test/openssl/test_ssl.rb:124:in block in start_server'

Thanks much for your help with any of these. Just wanted to bring them to public knowledge, as well as the next ones.
-=r
=end

Actions #1

Updated by yugui (Yuki Sonoda) almost 13 years ago

  • Assignee set to nobu (Nobuyoshi Nakada)
  • Target version set to 1.9.2

=begin

=end

Actions #2

Updated by usa (Usaku NAKAMURA) about 12 years ago

  • Category set to ext
  • Status changed from Open to Feedback

=begin
Roger, do these failures still exists?
I cannot reproduce them on mswin...
I want to identify the problem part; mingw? openssl itself? or others?
=end

Actions #3

Updated by rogerdpack (Roger Pack) about 12 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

=begin
It appears fixed now with

ruby 1.9.3dev (2010-06-03 trunk 28150) [i386-mingw32] (using "OpenSSL 0.9.8h 28 May 2008")

The only failures I see with make test-all are:
http://gist.github.com/424180
(12 failures)

Thanks for the improvement.

-roger
=end

Actions #4

Updated by usa (Usaku NAKAMURA) about 12 years ago

=begin
Hello,

In message "[ruby-core:30577] [Bug #1541][Closed] mingw ssl: Errno::ENOTSOCK: An operation was attempted on something that is not a socket."
on Jun.04,2010 02:23:43, wrote:

It appears fixed now with

ruby 1.9.3dev (2010-06-03 trunk 28150) [i386-mingw32] (using "OpenSSL 0.9.8h 28 May 2008")

The only failures I see with make test-all are:
http://gist.github.com/424180
(12 failures)

Thanks for the improvement.

Thank you for reporting!

short comments to your failures:

  1. #3387, and fixed at r28156
  2. bug of test. it's skipped on ruby_1_9_2
  3. unknown and cannot reproduce. I'm using
    "OpenSSL 1.0.0 29 Mar 2010", build by myself
  4. #3370, and seki-san is trying now.
  5. unknown and cannot reproduce. environment (codepage) dependent?
  6. ditto.
  7. ditto.
  8. ditto.
  9. unknown and cannot reproduce. environment (timezone) dependent?
  10. I decide that this is a problem of GDBM.
  11. ditto.
  12. cannot reproduce. hmm?
    59)-61) http://rubyforge.org/tracker/index.php?func=detail&aid=28249&group_id=627&atid=2472
  13. unknown and cannot reproduce. hmm?
  14. similar to #3345, and it's fixed at r28037 and related commits.
    did you install before running test-all?
  15. cannot reproduce. environment (codepage) dependent?

Regards,

U.Nakamura

=end

Actions #5

Updated by usa (Usaku NAKAMURA) about 12 years ago

=begin
Hello,

In message "[ruby-core:30581] Re: [Bug #1541][Closed] mingw ssl: Errno::ENOTSOCK: An operation was attempted on something that is not a socket."
on Jun.04,2010 11:58:13, wrote:

  1. similar to #3345, and it's fixed at r28037 and related commits.
    did you install before running test-all?

Oops, sorry, this is not fixed yet.
My WEBrick is patched. So, #3345 is still oepn.

Regards,

U.Nakamura

=end

Actions

Also available in: Atom PDF