Project

General

Profile

Actions

Bug #15469

closed

Ruby2.6 included `bundler` does not handle specified `csv` gem.

Added by watson1978 (Shizuo Fujita) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:90742]

Description

I want to use csv library which is same version of Ruby 2.5.
Because Ruby 2.6's csv library has some breaking changes and they break our product.

However, Ruby 2.6's bundler does not handle csv which I specified the version.

Test code

  • Gemfile
source "https://rubygems.org"

gem 'roo'
gem 'csv', '1.0.0'
  • test.rb
require "bundler/setup"
require "csv"

p CSV::VERSION

Result

$ bundle exec ruby -v test.rb
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-darwin18]
"3.0.2"

CSV::VERSION shows 3.0.2 and it indicates that Ruby 2.6 included csv library was used.

Workaround

If I install the bundler gem through gem install bundler, it works well.

$ gem install bundler
Fetching bundler-1.17.3.gem
Successfully installed bundler-1.17.3
1 gem installed

$ bundle exec ruby -v test.rb
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-darwin18]
"2.4.8"

Files

15469-bundler-loadpath.patch (528 Bytes) 15469-bundler-loadpath.patch hsbt (Hiroshi SHIBATA), 02/02/2019 08:29 AM
r15469-bundler-final.patch (1.69 KB) r15469-bundler-final.patch hsbt (Hiroshi SHIBATA), 02/05/2019 06:14 AM

Related issues

Related to Ruby master - Bug #15500: Behavior of require method in 2.5 is different from 2.4 and 2.6Closedhsbt (Hiroshi SHIBATA)Actions
Actions

Also available in: Atom PDF