Project

General

Profile

Actions

Bug #16028

closed

Backport r67563: SNI is not enabled in Net::IMAP

Added by hone (Terence Lee) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
[ruby-core:94001]

Description

There was an issue already created for https://bugs.ruby-lang.org/issues/15594 as a backport for Ruby 2.6 by naruse: https://bugs.ruby-lang.org/issues/15769. Can we get this backported to Ruby 2.5 and 2.4? This affects users on Ubuntu 18.04 LTS since the openssl package has been updated from 1.1.0 to 1.1.1, check this link for more details: https://bugs.launchpad.net/ubuntu/+source/uw-imap/+bug/1834340/comments/3.


Related issues

Related to Ruby master - Feature #15594: [PATCH] net/imap: support SNIClosedshugo (Shugo Maeda)Actions
Is duplicate of Ruby master - Bug #15769: Backport r67563: SNI is not enabled in Net::IMAPClosednaruse (Yui NARUSE)Actions
Actions #1

Updated by hone (Terence Lee) over 2 years ago

Actions #2

Updated by hone (Terence Lee) over 2 years ago

  • Related to Bug #15769: Backport r67563: SNI is not enabled in Net::IMAP added
Actions #3

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Is duplicate of Bug #15769: Backport r67563: SNI is not enabled in Net::IMAP added
Actions #4

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Related to deleted (Bug #15769: Backport r67563: SNI is not enabled in Net::IMAP)

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Status changed from Open to Closed

Duplicate of #15769, which requires to be backported to also 2.4 and 2.5.
Only closed ticket will be backported.

Updated by usa (Usaku NAKAMURA) over 2 years ago

  • Backport changed from 2.5: REQUIRED, 2.4: REQUIRED to 2.5: DONE, 2.4: REQUIRED

already backported into ruby_2_5 at r67717

Actions

Also available in: Atom PDF