Project

General

Profile

Actions

Bug #18570

closed

Please Backport 77fe1fca0abb56f7f07725c0a3803d53a315c853 from the ipaddr gem to Ruby 3.1

Added by dcermak (Dan Čermák) 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:107477]

Description

For some reason the following code causes an exception with Ruby 3.1:

require "ipaddr"
([IPAddr.new("192.168.56.0/21").freeze].freeze).any?{ |range| range.include?(IPAddr.new("192.168.1.0")) }

which breaks vagrant with Ruby 3.1.

The issue has been fixed via commit 77fe1fca0abb56f7f07725c0a3803d53a315c853. Can you please backport it to 3.1 for a maintenance release?

Actions

Also available in: Atom PDF