Project

General

Profile

Bug #1984

unable to require '.so' files with full directory path

Added by rogerdpack (Roger Pack) over 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
1.9.2 mingw
Backport:
[ruby-core:25075]

Description

=begin
where c:\dev\go.rb exists

c:\dev>irb

require "\dev\go"
=> true

you can require it by absolute path.

However with c:\dev\go.so exists, you cannot.
Thanks.
=end

History

#1

Updated by yugui (Yuki Sonoda) over 10 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Assignee set to nobu (Nobuyoshi Nakada)
  • Priority changed from Normal to 5
  • Target version set to 1.9.2

=begin

=end

#2

Updated by nobu (Nobuyoshi Nakada) over 10 years ago

=begin
Hi,

At Mon, 24 Aug 2009 14:01:17 +0900,
Roger Pack wrote in [ruby-core:25075]:

Author: Roger Pack
Status: Open, Priority: Normal
ruby -v: 1.9.2 mingw

What revision?

where c:\dev\go.rb exists
you can require it by absolute path.

However with c:\dev\go.so exists, you cannot.

I can't reproduce it.

--
Nobu Nakada

=end

#3

Updated by nobu (Nobuyoshi Nakada) over 10 years ago

  • Status changed from Assigned to Feedback

=begin

=end

#4

Updated by rogerdpack (Roger Pack) over 10 years ago

=begin
Hmm. I can't reproduce with 1.9 either, I thought I had been able to but apparently not.

With 1.8 it's

C:\dev\ruby\recr>irb

require "\dev\ruby\recr\mytest"
LoadError: 127: The specified procedure could not be found. - Init_\dev\ruby\recr\mytest
\dev\ruby\recr\mytest.so
from \dev\ruby\recr\mytest.so
from (irb):1
from :0
require '\dev\ruby\recr\mytest'
LoadError: 127: The specified procedure could not be found. - Init_\dev\ruby\recr\mytest
\dev\ruby\recr\mytest.so
from \dev\ruby\recr\mytest.so
from (irb):2
from :0
require '/dev/ruby/recr/mytest'
=> true # this one works for some reason.

-r

=end

#5

Updated by naruse (Yui NARUSE) over 10 years ago

  • Status changed from Feedback to Closed

=begin

=end

Also available in: Atom PDF