Project

General

Profile

Backport #3288

Segmentation fault - activesupport-3.0.0.beta3/lib/active_support/callbacks.rb:88

Added by jeznet (Szymon Jeż) about 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:30226]

Description

=begin

rails server

=> Booting WEBrick

=> Rails 3.0.0.beta3 application starting in development on http://0.0.0.0:3000
=> Call with -d to detach

=> Ctrl-C to shutdown server

[2010-05-13 23:16:04] INFO WEBrick 1.3.1

[2010-05-13 23:16:04] INFO ruby 1.9.1 (2010-01-10) [x86_64-linux]

[2010-05-13 23:16:09] INFO WEBrick::HTTPServer#start: pid=9678 port=3000

# Now I request any databese using Rails action

(eval):1: [BUG] Segmentation fault

ruby 1.9.1p378 (2010-01-10 revision 26273) [x86_64-linux]

-- control frame ----------
c:0023 p:-3803124 s:0136 b:0135 l:000134 d:000134 METHOD (eval):1
c:0022 p:0024 s:0125 b:0125 l:000124 d:000124 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-3.0.0.beta3/lib/active_support/callbacks.rb:88

c:0021 p:0013 s:0119 b:0119 l:001b80 d:001b80 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/callbacks.rb:44

c:0020 p:0014 s:0115 b:0115 l:000114 d:000114 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/sendfile.rb:105

c:0019 p:0046 s:0105 b:0105 l:000104 d:000104 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/remote_ip.rb:48

c:0018 p:0014 s:0101 b:0101 l:000100 d:000100 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/show_exceptions.rb:48

c:0017 p:0026 s:0096 b:0096 l:000095 d:000095 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/rack/logger.rb:13

c:0016 p:0031 s:0092 b:0092 l:000091 d:000091 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/runtime.rb:17

c:0015 p:0013 s:0083 b:0083 l:000077 d:000082 BLOCK /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/lock.rb:11

c:0014 p:0019 s:0081 b:0081 l:000080 d:000080 METHOD internal:prelude:8

c:0013 p:0052 s:0078 b:0078 l:000077 d:000077 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/lock.rb:11

c:0012 p:0189 s:0073 b:0073 l:000072 d:000072 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/static.rb:30

c:0011 p:0032 s:0066 b:0066 l:000065 d:000065 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/application.rb:132

c:0010 p:0021 s:0062 b:0062 l:000061 d:000061 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/application.rb:81

c:0009 p:---- s:0057 b:0057 l:000056 d:000056 FINISH

c:0008 p:0014 s:0055 b:0055 l:000054 d:000054 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/rack/log_tailer.rb:15
c:0007 p:0014 s:0050 b:0050 l:000049 d:000049 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/content_length.rb:13

c:0006 p:0320 s:0042 b:0042 l:000041 d:000041 METHOD /home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/handler/webrick.rb:48

c:0005 p:0256 s:0030 b:0030 l:000029 d:000029 METHOD /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/httpserver.rb:111

c:0004 p:0382 s:0020 b:0020 l:000019 d:000019 METHOD /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/httpserver.rb:70

c:0003 p:0123 s:0009 b:0009 l:000ac8 d:000008 BLOCK /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/server.rb:183

c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH

c:0001 p:---- s:0002 b:0002 l:000001 d:000001 TOP


-- Ruby level backtrace information-----------------------------------------

(eval):1:in api_delegate'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-3.0.0.beta3/lib/active_support/callbacks.rb:88:in
run_callbacks'

/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/callbacks.rb:44:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/sendfile.rb:105:in
call'

/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/remote_ip.rb:48:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/show_exceptions.rb:48:in
call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/rack/logger.rb:13:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/runtime.rb:17:in
call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/lock.rb:11:in block in call'
<internal:prelude>:8:in
synchronize'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/lock.rb:11:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta3/lib/action_dispatch/middleware/static.rb:30:in
call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/application.rb:132:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/application.rb:81:in
method_missing'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/railties-3.0.0.beta3/lib/rails/rack/log_tailer.rb:15:in call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/content_length.rb:13:in
call'
/home/jeznet/.rvm/gems/ruby-1.9.1-p378/gems/rack-1.1.0/lib/rack/handler/webrick.rb:48:in service'
/home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/httpserver.rb:111:in
service'
/home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/httpserver.rb:70:in run'
/home/jeznet/.rvm/rubies/ruby-1.9.1-p378/lib/ruby/1.9.1/webrick/server.rb:183:in
block in start_thread'

-- C level backtrace information -------------------------------------------
0x4e26c1 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby(rb_vm_bugreport+0x41) [0x4e26c1]
0x50f258 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x50f258]
0x50f3c1 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby(rb_bug+0xb1) [0x50f3c1]
0x48ff68 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x48ff68]
0x7f01c3442190 /lib/libpthread.so.0 [0x7f01c3442190]
0x4d44e0 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4d44e0]
0x4d9b92 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4d9b92]
0x4dcbbb /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4dcbbb]
0x4ddd37 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby(rb_funcall2+0x107) [0x4ddd37]
0x4ddf65 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4ddf65]
0x4d4232 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4d4232]
0x4d6bdc /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4d6bdc]
0x4d9b92 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4d9b92]
0x4dc74f /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby(rb_vm_invoke_proc+0x27f) [0x4dc74f]
0x4e6852 /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4e6852]
0x4e698e /home/jeznet/.rvm/rubies/ruby-1.9.1-p378/bin/ruby [0x4e698e]
0x7f01c3439a04 /lib/libpthread.so.0 [0x7f01c3439a04]
0x7f01c28da80d /lib/libc.so.6(clone+0x6d) [0x7f01c28da80d]

Aborted

=end

History

#1

Updated by tenderlovemaking (Aaron Patterson) about 9 years ago

=begin
Can you provide us with more information?

Can you reproduce this using trunk ruby?

Can you provide us with the source of your rails app including what it depends on?
=end

#2

Updated by jeznet (Szymon Jeż) about 9 years ago

=begin
Using trunk ruby (rvm install 1.9.2-head) i cant reproduce this error. I get:

rails server
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

-- control frame ----------
c:0050 p:---- s:0136 b:0136 l:000135 d:000135 CFUNC :alias_method
c:0049 p:0044 s:0131 b:0131 l:000130 d:000130 CLASS /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0048 p:0009 s:0129 b:0129 l:000128 d:000128 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0047 p:---- s:0127 b:0127 l:000126 d:000126 FINISH

c:0046 p:---- s:0125 b:0125 l:000124 d:000124 CFUNC :require

c:0045 p:0023 s:0121 b:0121 l:000120 d:000120 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0044 p:---- s:0119 b:0119 l:000118 d:000118 FINISH

c:0043 p:---- s:0117 b:0117 l:000116 d:000116 CFUNC :require

c:0042 p:0011 s:0113 b:0113 l:000112 d:000112 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0041 p:---- s:0111 b:0111 l:000110 d:000110 FINISH

c:0040 p:---- s:0109 b:0109 l:000108 d:000108 CFUNC :require

c:0039 p:0011 s:0105 b:0105 l:000104 d:000104 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0038 p:---- s:0103 b:0103 l:000102 d:000102 FINISH

c:0037 p:---- s:0101 b:0101 l:000100 d:000100 CFUNC :require

c:0036 p:0035 s:0097 b:0097 l:000096 d:000096 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0035 p:---- s:0095 b:0095 l:000094 d:000094 FINISH

c:0034 p:---- s:0093 b:0093 l:000092 d:000092 CFUNC :require

c:0033 p:0023 s:0089 b:0089 l:000088 d:000088 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0032 p:---- s:0087 b:0087 l:000086 d:000086 FINISH

c:0031 p:---- s:0085 b:0085 l:000084 d:000084 CFUNC :require

c:0030 p:0076 s:0081 b:0081 l:000080 d:000080 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstra

c:0029 p:---- s:0078 b:0078 l:000077 d:000077 FINISH

c:0028 p:---- s:0076 b:0076 l:000075 d:000075 CFUNC :require

c:0027 p:0011 s:0072 b:0072 l:000071 d:000071 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action

c:0026 p:---- s:0070 b:0070 l:000069 d:000069 FINISH

c:0025 p:---- s:0068 b:0068 l:000067 d:000067 CFUNC :require

c:0024 p:0023 s:0064 b:0064 l:000063 d:000063 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action

c:0023 p:---- s:0062 b:0062 l:000061 d:000061 FINISH

c:0022 p:---- s:0060 b:0060 l:000059 d:000059 CFUNC :require

c:0021 p:0047 s:0056 b:0056 l:000055 d:000055 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/acti

c:0020 p:---- s:0054 b:0054 l:000053 d:000053 FINISH

c:0019 p:---- s:0052 b:0052 l:000051 d:000051 CFUNC :require

c:0018 p:0021 s:0048 b:0048 l:000039 d:000047 BLOCK /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/al

c:0017 p:---- s:0045 b:0045 l:000044 d:000044 FINISH

c:0016 p:---- s:0043 b:0043 l:000042 d:000042 CFUNC :each

c:0015 p:0032 s:0040 b:0040 l:000039 d:000039 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/al

c:0014 p:---- s:0038 b:0038 l:000037 d:000037 FINISH

c:0013 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC :require

c:0012 p:0038 s:0032 b:0032 l:000031 d:000031 TOP /home/jeznet/projekty/poligon/spitelad/src/app/config/application.rb:3

c:0011 p:---- s:0030 b:0030 l:000029 d:000029 FINISH

c:0010 p:---- s:0028 b:0028 l:000027 d:000027 CFUNC :require

c:0009 p:0016 s:0024 b:0024 l:000015 d:000023 BLOCK /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/co

c:0008 p:---- s:0021 b:0021 l:000020 d:000020 FINISH

c:0007 p:---- s:0019 b:0019 l:000018 d:000018 CFUNC :tap

c:0006 p:0442 s:0016 b:0016 l:000015 d:000015 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/co

c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH

c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :require

c:0003 p:0097 s:0006 b:0006 l:000738 d:000b28 EVAL script/rails:9

c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH

c:0001 p:0000 s:0002 b:0002 l:000738 d:000738 TOP


-- Ruby level backtrace information-----------------------------------------

script/rails:9:in <main>'
script/rails:9:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:27:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:27:in
tap'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:28:in block in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:28:in
require'

/home/jeznet/projekty/poligon/spitelad/src/app/config/application.rb:3:in <top (required)>'
/home/jeznet/projekty/poligon/spitelad/src/app/config/application.rb:3:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:5:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:5:in
each'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:11:in block in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:11:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/active_record/railtie.rb:9:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/active_record/railtie.rb:9:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller/railtie.rb:2:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller/railtie.rb:2:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstract_controller.rb:4:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstract_controller.rb:4:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/ruby/shim.rb:12:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/ruby/shim.rb:12:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/date/calculations.rb:3:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/date/calculations.rb:3:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/time/zones.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/time/zones.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/time_with_zone.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/time_with_zone.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/values/time_zone.rb:2:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/values/time_zone.rb:2:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29:in
class:Object'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29:in `alias_method'

-- C level backtrace information -------------------------------------------
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_vm_bugreport+0x9f) [0x515a2f]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5514b8]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_bug+0xb1) [0x551671]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_alias+0x102) [0x511722]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x51194a]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_yield+0x228) [0x513ae8]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_ary_each+0x45) [0x523ee5]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_yield+0x228) [0x513ae8]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_obj_tap+0x9) [0x44e3f9]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval_main+0x269) [0x50c369]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(ruby_exec_node+0xb2) [0x419a62]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(ruby_run_node+0x37) [0x41b537]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(main+0x49) [0x418c19]
/lib/libc.so.6(__libc_start_main+0xfd) [0x7fe2712a8abd]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x418b09]

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.

The dependency of the app:

# Gemfile of the app:
source 'http://rubygems.org'

#gem 'rails', '3.0.0.beta3'

# Bundle edge Rails instead:
gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3-ruby', :require => 'sqlite3'
gem "pg"

gem 'acts_as_tree', :git => 'http://github.com/parasew/acts_as_tree.git'
gem 'tree_select', :git => 'git://github.com/jeznet/tree_select.git'

The code of the app i pretty a stub app generated by the rails command + some basic scaffolding.
=end

#3

Updated by mame (Yusuke Endoh) about 9 years ago

=begin
Hi,

Thank you for your help.

2010/5/19 Szymon Je? redmine@ruby-lang.org:

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

This issue seems like [Bug #2051] which is already fixed.

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

It is very old trunk, though I don't know the reason.
Anyone here is familiar with rvm?

--
Yusuke Endoh mame@tsg.ne.jp

=end

#4

Updated by Cezary (Cezary Baginski) about 9 years ago

=begin
On Wed, May 19, 2010 at 11:45:44PM +0900, Yusuke ENDOH wrote:

Hi,

Thank you for your help.

2010/5/19 Szymon Je? redmine@ruby-lang.org:

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

This issue seems like [Bug #2051] which is already fixed.

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

It is very old trunk, though I don't know the reason.
Anyone here is familiar with rvm?

Somewhat.

Probably done with a very old rvm version, when versions marked
1.9.2-head versions still referenced trunk.

The following is always suggested:

$ rvm update --head # for lots of reasons

The mentioned:

$ rvm install 1.9.2-head

now uses branches/ruby_1_9_2 instead of trunk, so updating rvm and
reinstalling the same ruby version should fix everything.

Currently, I get r27902 using the same command.

Cheers!

--
Cezary Baginski

Attachment: signature.asc
=end

#5

Updated by jeznet (Szymon Jeż) about 9 years ago

=begin
Cezary I updated RVM as You suggested (thanks for the tip (Dzięki ;) )). Now I'm getting this:

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

-- control frame ----------
c:0050 p:---- s:0136 b:0136 l:000135 d:000135 CFUNC :alias_method
c:0049 p:0044 s:0131 b:0131 l:000130 d:000130 CLASS /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0048 p:0009 s:0129 b:0129 l:000128 d:000128 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0047 p:---- s:0127 b:0127 l:000126 d:000126 FINISH

c:0046 p:---- s:0125 b:0125 l:000124 d:000124 CFUNC :require

c:0045 p:0023 s:0121 b:0121 l:000120 d:000120 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0044 p:---- s:0119 b:0119 l:000118 d:000118 FINISH

c:0043 p:---- s:0117 b:0117 l:000116 d:000116 CFUNC :require

c:0042 p:0011 s:0113 b:0113 l:000112 d:000112 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0041 p:---- s:0111 b:0111 l:000110 d:000110 FINISH

c:0040 p:---- s:0109 b:0109 l:000108 d:000108 CFUNC :require

c:0039 p:0011 s:0105 b:0105 l:000104 d:000104 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0038 p:---- s:0103 b:0103 l:000102 d:000102 FINISH

c:0037 p:---- s:0101 b:0101 l:000100 d:000100 CFUNC :require

c:0036 p:0035 s:0097 b:0097 l:000096 d:000096 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0035 p:---- s:0095 b:0095 l:000094 d:000094 FINISH

c:0034 p:---- s:0093 b:0093 l:000092 d:000092 CFUNC :require

c:0033 p:0023 s:0089 b:0089 l:000088 d:000088 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/act

c:0032 p:---- s:0087 b:0087 l:000086 d:000086 FINISH

c:0031 p:---- s:0085 b:0085 l:000084 d:000084 CFUNC :require

c:0030 p:0076 s:0081 b:0081 l:000080 d:000080 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstra

c:0029 p:---- s:0078 b:0078 l:000077 d:000077 FINISH

c:0028 p:---- s:0076 b:0076 l:000075 d:000075 CFUNC :require

c:0027 p:0011 s:0072 b:0072 l:000071 d:000071 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action

c:0026 p:---- s:0070 b:0070 l:000069 d:000069 FINISH

c:0025 p:---- s:0068 b:0068 l:000067 d:000067 CFUNC :require

c:0024 p:0023 s:0064 b:0064 l:000063 d:000063 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action

c:0023 p:---- s:0062 b:0062 l:000061 d:000061 FINISH

c:0022 p:---- s:0060 b:0060 l:000059 d:000059 CFUNC :require

c:0021 p:0047 s:0056 b:0056 l:000055 d:000055 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/acti

c:0020 p:---- s:0054 b:0054 l:000053 d:000053 FINISH

c:0019 p:---- s:0052 b:0052 l:000051 d:000051 CFUNC :require

c:0018 p:0021 s:0048 b:0048 l:000039 d:000047 BLOCK /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/al

c:0017 p:---- s:0045 b:0045 l:000044 d:000044 FINISH

c:0016 p:---- s:0043 b:0043 l:000042 d:000042 CFUNC :each

c:0015 p:0032 s:0040 b:0040 l:000039 d:000039 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/al

c:0014 p:---- s:0038 b:0038 l:000037 d:000037 FINISH

c:0013 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC :require

c:0012 p:0038 s:0032 b:0032 l:000031 d:000031 TOP /home/jeznet/projekty/poligon/render-test/config/application.rb:3

c:0011 p:---- s:0030 b:0030 l:000029 d:000029 FINISH

c:0010 p:---- s:0028 b:0028 l:000027 d:000027 CFUNC :require

c:0009 p:0016 s:0024 b:0024 l:000015 d:000023 BLOCK /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/co

c:0008 p:---- s:0021 b:0021 l:000020 d:000020 FINISH

c:0007 p:---- s:0019 b:0019 l:000018 d:000018 CFUNC :tap

c:0006 p:0442 s:0016 b:0016 l:000015 d:000015 TOP /home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/co

c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH

c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :require

c:0003 p:0097 s:0006 b:0006 l:0000e8 d:0004d8 EVAL script/rails:9

c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH

c:0001 p:0000 s:0002 b:0002 l:0000e8 d:0000e8 TOP


-- Ruby level backtrace information-----------------------------------------

script/rails:9:in <main>'
script/rails:9:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:27:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:27:in
tap'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:28:in block in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/commands.rb:28:in
require'

/home/jeznet/projekty/poligon/render-test/config/application.rb:3:in <top (required)>'
/home/jeznet/projekty/poligon/render-test/config/application.rb:3:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:5:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:5:in
each'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:11:in block in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/railties/lib/rails/all.rb:11:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/active_record/railtie.rb:9:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activerecord/lib/active_record/railtie.rb:9:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller/railtie.rb:2:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller/railtie.rb:2:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/action_controller.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstract_controller.rb:4:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/actionpack/lib/abstract_controller.rb:4:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/ruby/shim.rb:12:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/ruby/shim.rb:12:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/date/calculations.rb:3:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/date/calculations.rb:3:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/time/zones.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/time/zones.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/time_with_zone.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/time_with_zone.rb:1:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/values/time_zone.rb:2:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/values/time_zone.rb:2:in
require'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:1:in <top (required)>'
/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29:in
class:Object'

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29:in `alias_method'

-- C level backtrace information -------------------------------------------
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_vm_bugreport+0x9f) [0x515a2f]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5514b8]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_bug+0xb1) [0x551671]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_alias+0x102) [0x511722]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x51194a]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_yield+0x228) [0x513ae8]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_ary_each+0x45) [0x523ee5]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]

/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_yield+0x228) [0x513ae8]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_obj_tap+0x9) [0x44e3f9]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval+0x1b0) [0x50c550]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5535e4]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_require_safe+0x63f) [0x554dbf]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x5005c2]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x512001]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x507fdb]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x50c02b]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(rb_iseq_eval_main+0x269) [0x50c369]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(ruby_exec_node+0xb2) [0x419a62]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(ruby_run_node+0x37) [0x41b537]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby(main+0x49) [0x418c19]
/lib/libc.so.6(__libc_start_main+0xfd) [0x7fd3e768eabd]
/home/jeznet/.rvm/rubies/ruby-1.9.2-preview1/bin/ruby [0x418b09]

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries

Looks to me as the same bug.
=end

#6

Updated by Cezary (Cezary Baginski) about 9 years ago

=begin
On Fri, May 21, 2010 at 08:54:57PM +0900, Szymon Jeż wrote:

Issue #3288 has been updated by Szymon Jeż.

Cezary I updated RVM as You suggested (thanks for the tip (Dzięki ;) )).

Glad to help!

Now I'm getting this:

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

24186 is still too old. You still have to reinstall the Ruby version,
for rvm to update the sources and rebuild:

$ rvm install 1.9.2-head

or

$ rvm install --force 1.9.2-head

If you still have a ruby 1.9.2-head version with a revision less than
say, 27902, you should try the rvm mailing
(http://rvm.beginrescueend.com/support/)

Before posting to ruby-core again with the same problem,
try also ruby-head in rvm to see if the problem has been fixed already
and may need backporting.

Hope this helps.

--
Cezary Baginski

Attachment: signature.asc
=end

#7

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Status changed from Open to Rejected

=begin

=end

#8

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Status changed from Rejected to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

#9

Updated by jeznet (Szymon Jeż) about 9 years ago

=begin
I finally made to run the app on Ruby 1.9.2dev (2010-05-21 revision 27947). The app starts fine. No errors. The same on Ruby 1.9.1p378 (2010-01-10 revision 26273). Ruby 1.9.2dev (2009-07-18 trunk 24186) has the bug I reported before ([BUG] rb_add_method: unsupported method type).

I cant reproduce the segmentation fault bug on Ruby 1.9.1 I reported in the first place.

Cezary (Cezary Baginski) Baginski
I have done the reinstallation of Ruby 1.9.2 before. I used rvm install 1.9.2-head as you suggested. But I think I have fallen to a bug in rvm I have found today:

jeznet@kolec:~/app$ rvm 1.9.2-head
jeznet@kolec:~/app$ ruby -v

ruby 1.9.2dev (2010-05-21 revision 27947) [x86_64-linux]
jeznet@kolec:~/app$ rails server

/home/jeznet/.rvm/gems/ruby-1.9.2-head/bundler/gems/rails-16a5e918a06649ffac24fd5873b875daf66212ad-master/activesupport/lib/active_support/core_ext/object/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

-- control frame ----------
c:0050 p:---- s:0136 b:0136 l:000135 d:000135 CFUNC :alias_method

ruby -v gives patch level 27947 but the app start running on 24186. Strange. I will ask about it on the rvm mailing list.
=end

#10

Updated by mame (Yusuke Endoh) almost 9 years ago

=begin
Hi,

I finally made to run the app on Ruby 1.9.2dev (2010-05-21 revision 27947). The app starts fine. No errors. The same on Ruby 1.9.1p378 (2010-01-10 revision 26273). Ruby 1.9.2dev (2009-07-18 trunk 24186) has the bug I reported before ([BUG] rb_add_method: unsupported method type).

I cant reproduce the segmentation fault bug on Ruby 1.9.1 I reported in the first place.

Thank you for confirming, but it's weird...

Cezary (Cezary Baginski) Baginski
I have done the reinstallation of Ruby 1.9.2 before. I used rvm install 1.9.2-head as you suggested. But I think I have fallen to a bug in rvm I have found today:

snip

ruby -v gives patch level 27947 but the app start running on 24186. Strange. I will ask about it on the rvm mailing list.

I wonder you have used wrong version of Ruby due to rvm...?
I may have to add to FAQ, "is it reproduced without rvm?"

Anyway, there seems to be no bug (or already fixed).
May I close this ticket?
If you will get new information indicating that this is not
rvm's bug but core's, feel free to reopen this.

--
Yusuke Endoh mame@tsg.ne.jp
=end

#11

Updated by jeznet (Szymon Jeż) almost 9 years ago

=begin

May I close this ticket?
Yes, please.

About the rvm "bug" with running app on a different ruby as expected. This was not a bug. I find out that the 'rails' script has a shebang pointing to a specific ruby interpreter (not #!/usr/bin/env ruby as i thought). And because I copied some gems from 1.9.2-preview to 1.9.2-head a had this behavior.

So summing up. This bugs where due to not using the newest versions of Ruby and or RVM.
Thanks for you patience and support.
=end

#12

Updated by mame (Yusuke Endoh) almost 9 years ago

  • Status changed from Assigned to Closed

=begin

=end

Also available in: Atom PDF