Project

General

Profile

Feature #4647

[PATCH] io/wait: add IO#wait_writable method

Added by Eric Wong over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:36006]

Description

This is easier to use than IO.select for a single IO object
and is immune to the limitations/innefficiency of select()
on platforms where poll/ppoll is available.

0001-io-wait-add-IO-wait_writable-method.patch View (3.11 KB) Eric Wong, 05/05/2011 07:26 AM


Related issues

Duplicates Ruby trunk - Feature #4646: [PATCH] io/wait: add IO#wait_writable method Closed 05/05/2011

History

#1 [ruby-core:36035] Updated by Eric Wong over 5 years ago

Eric Wong normalperson@yhbt.net wrote:

Issue #4647 has been reported by Eric Wong.

Oops, this is a duplicate of #4646 I screwed up using my web browser.

#2 [ruby-core:43916] Updated by Yusuke Endoh over 4 years ago

  • Status changed from Open to Assigned
  • Assignee set to Nobuyoshi Nakada

#3 [ruby-core:48353] Updated by Koichi Sasada about 4 years ago

  • Status changed from Assigned to Closed

I closed this ticket because it is duplicated.

Also available in: Atom PDF