Project

General

Profile

Backport #5099

Backport r31875 load path performance problem

Added by tenderlovemaking (Aaron Patterson) almost 8 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
[ruby-core:38526]

Description

Would it be possible to backport r31875 to 1.9.2? I think 1.9.2 users are still suffering.

Thanks!


Files

ruby-1.9.2-p290-load-path-backport.diff (1016 Bytes) ruby-1.9.2-p290-load-path-backport.diff Backport patch against ruby-1.9.2-p290 cwgem (Chris White), 08/04/2011 03:09 AM

History

Updated by joshk (Josh Kalderimis) almost 8 years ago

Hi Guys,

Please backport this fix to 1.9.2.

Travis CI (http://travis-ci.org) shows some great examples of the issues caused by the slow requires in 1.9.2.

For example the Rails test suite (http://travis-ci.org/#!/rails/rails/builds/64519), especially the Railties tests, explodes from 13 minutes when we test it against 1.8.7 to 28mins on 1.9.2.

The Rails test suite does a lot of isolated testing, so although this is an exaggerated case, it goes to show how this requires issue slows down testing and development in general.

Here are some other tests which are slower to run on 1.9.2:

http://travis-ci.org/#!/intridea/omniauth/builds/57098
http://travis-ci.org/#!/rspec/rspec-rails/builds/64368

and finally

http://travis-ci.org/#!/mongoid/mongoid/builds/64365 (this is a great example of 1.8.7 vs 1.9.2 vs 1.9.3)

Kind Regards,

Josh and the Travis CI team

Updated by antares (Michael Klishin) almost 8 years ago

I second this request. It is surprising how little attention this performance regression had gotten. Many applications went from 5 seconds load time to 35. Running a single test in some codebases now takes seconds instead of 0.1th of a second it used to take.

Please backport this to 1.9.2-head and make a release soon. Thank you.

Updated by luislavena (Luis Lavena) almost 8 years ago

Hello,

I believe Aaron's request, Josh Kalderimis reasoning and explanation are enough to describe this issue.

Please avoid flooding it with meaningless +1 that do not add value. It is clear the importance of this and the 1.9.2 maintainer will determine if the changes can be considered for backport or not.

Thank you.

Updated by antares (Michael Klishin) almost 8 years ago

Luis: I am sorry but this and YAML parser bug backports have been ignored for months. It is time to step up and bring this to 1.9.2 maintainers attention. Issues like this make me strongly believe that Ruby Core Team doesn't give a damn about 1.9.2. If 35 freaking seconds is not enough of a reason to backport, I don't know what is.

Updated by luislavena (Luis Lavena) almost 8 years ago

Michael Klishin wrote:

Luis: I am sorry but this and YAML parser bug backports have been ignored for months. It is time to step up and bring this to 1.9.2 maintainers attention. Issues like this make me strongly believe that Ruby Core Team doesn't give a damn about 1.9.2. If 35 freaking seconds is not enough of a reason to backport, I don't know what is.

The reasoning behind backports has been explained in the past. Bugs are candidates for backports as long it doesn't alter the default behavior of Ruby/stdlib/etc.

If you want to make more easy the life of the 1.9.2 maintainer, please, checkout the branch and perform the manual backport of the corresponding commits, then attach a diff here for the maintainer properly apply.

Sometimes what you consider "35 freaking seconds" takes time when you need to perform lot of other tasks.

Please, don't be disrespectful on other's time availability. If you're not pleased, then prove you're a better release maintainer and step up.

Updated by cwgem (Chris White) almost 8 years ago

Attached is a backport patch to be applied against ruby-1.9.2-p290. All of ruby compiles and make test shows no complaints. Though the function signatures are the same and I don't see the patch breaking anything, please apply and give it a shot for a 1.9.2 in an ISOLATED NON-PRODUCTION ENVIRONMENT, unless that is you're feeling adventurous :)

Updated by boblin (Bohuslav Blín) almost 8 years ago

+1.

Thank's Aaron for opening this painful issue.

Updated by vishnu.atrai (Vishnu Atrai) almost 8 years ago

It would be better to have it in ruby 1.9.2 . This patch looks good.

Updated by kronos (Ivan Samsonov) almost 8 years ago

+1. It's very important for me and my projects

#19

Updated by naruse (Yui NARUSE) about 3 years ago

  • Status changed from Open to Rejected

Also available in: Atom PDF