Project

General

Profile

Actions

Bug #5772

closed

Segmentation Fault on Mac (crash)

Added by maxkir (Kirill Maximov) over 10 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
ruby -v:
ruby 1.9.3p0 (2011-10-30 revision 33570) [i386-darwin9.8.0]
Backport:
[ruby-core:<unknown>]

Description

I'm developing an Rails 3.1.3 application on a Mac:

Darwin kir-mac-2.local 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Periodically, once a day or more, the running application crashes (looks like some crash in GC code).

I've attached several Crash reports packed in a tgz file.

I have some GC-related settings:

kir-mac-2:CrashReporter kir$ env |grep RUBY
RUBY_HEAP_FREE_MIN=100000
MY_RUBY_HOME=/Users/kir/.rvm/rubies/ruby-1.9.3-p0
RUBY_HEAP_MIN_SLOTS=600000
RUBY_HEAP_SLOTS_INCREMENT=10000
RUBY_GC_MALLOC_LIMIT=59000000
RUBY_HEAP_SLOTS_GROWTH_FACTOR=1.8
RUBY_VERSION=ruby-1.9.3-p0


Files

crash_reports.tgz (52.2 KB) crash_reports.tgz maxkir (Kirill Maximov), 12/18/2011 02:02 AM
Actions #1

Updated by ko1 (Koichi Sasada) over 10 years ago

  • Assignee set to mrkn (Kenta Murata)
Actions #2

Updated by shyouhei (Shyouhei Urabe) over 10 years ago

  • Status changed from Open to Assigned

Updated by mrkn (Kenta Murata) about 10 years ago

  • Status changed from Assigned to Feedback

You use Leopard because the kernel version is 9.8.0.
We don't support Leopard so we want to know whether this issue is reproduced on the combination of the newest version of kernel (11.4.0) and the newest version of ruby (trunk or 1.9.3-p194).

Please give us the additional report.

Actions #4

Updated by naruse (Yui NARUSE) over 9 years ago

  • Target version changed from 1.9.3 to 2.6

Updated by naruse (Yui NARUSE) almost 9 years ago

  • Priority changed from 5 to Normal
Actions #6

Updated by naruse (Yui NARUSE) over 4 years ago

  • Target version deleted (2.6)

Updated by mame (Yusuke Endoh) about 4 years ago

  • Status changed from Feedback to Rejected

1.9.3 has been already dead. Please reopen if it still reproduces in recent versions.

Actions

Also available in: Atom PDF