Bug #6011

ruby-1.9.3-p0/lib/webrick/utils.rb:184: [BUG] Segmentation fault

Added by Vit Ondruch about 2 years ago. Updated almost 2 years ago.

[ruby-core:42560]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:1.9.3p125 (2012-02-16 revision 34643) [armv7hl-linux] Backport:

Description

Using Fedora 17 armv7hl, the test suite crashes with following segfault:

/builddir/build/BUILD/ruby-1.9.3-p0/lib/webrick/utils.rb:184:
[BUG] Segmentation fault
ruby 1.9.3p0 (2011-10-30) [armv7hl-linux]
-- Control frame information -----------------------------------------------
c:0007 p:---- s:0017 b:0017 l:000016 d:000016 CFUNC :resume
c:0006 p:0015 s:0014 b:0014 l:000bb0 d:0020b0 BLOCK
/builddir/build/BUILD/ruby-1.9.3-p0/test/ruby/testfiber.rb:55
c:786428817 p:---- s:0011 b:-60909305 l:000100 d:000100 FINISH
c:0004 p:---- s:0009 b:0009 l:000008 d:000008 CFUNC :times
c:0003 p:0011 s:0006 b:0006 l:000bb0 d:00164c BLOCK
/builddir/build/BUILD/ruby-1.9.3-p0/test/ruby/test
fiber.rb:54
c:0002 p:---- s:-60944928 b:0004 l:000003 d:000003 FINISH
c:0001 p:---- s:0002 b:0002 l:000001 d:000001 TOP

make: *** [yes-test-all] Segmentation fault

This was originally reported at https://bugzilla.redhat.com/show_bug.cgi?id=789410


Related issues

Related to ruby-trunk - Bug #5780: test/fileutils/test_fileutils.rb:86: [BUG] Segmentation f... Closed 12/20/2011

History

#1 Updated by Yui NARUSE about 2 years ago

Is this reproducible with ruby-1.9.3-p105?

#2 Updated by Yui NARUSE about 2 years ago

This is caused by #5700, fiber+fork.

#3 Updated by Vit Ondruch about 2 years ago

It seems that #6021 block this. I cannot test with p105 :/

#4 Updated by Yui NARUSE about 2 years ago

Vit Ondruch wrote:

It seems that #6021 block this. I cannot test with p105 :/

run make -x test_dbm.rb test-all

#5 Updated by Yui NARUSE about 2 years ago

  • Status changed from Open to Feedback

#7 Updated by Yui NARUSE about 2 years ago

Vit Ondruch wrote:

Unfortunately, it still fails: http://arm.koji.fedoraproject.org/koji/getfile?taskID=451175&name=build.log

Hmm, is it only reproduced on ARM?

#8 Updated by Vit Ondruch about 2 years ago

Yui NARUSE wrote:

Vit Ondruch wrote:

Unfortunately, it still fails: http://arm.koji.fedoraproject.org/koji/getfile?taskID=451175&name=build.log

Hmm, is it only reproduced on ARM?

Of course I test also on i686 and x86_64 and I cannot reproduce it there.

#9 Updated by Yui NARUSE about 2 years ago

  • Status changed from Feedback to Open
  • ruby -v changed from ruby-1.9.3-p0 to 1.9.3p125 (2012-02-16 revision 34643) [armv7hl-linux]

I don't have ARM knowledge.
If someone has an idea, contribution is welcome.

#10 Updated by Koichi Sasada about 2 years ago

  • Assignee set to Yusuke Endoh

#11 Updated by Shyouhei Urabe about 2 years ago

  • Status changed from Open to Assigned

#12 Updated by Yusuke Endoh about 2 years ago

  • Status changed from Assigned to Feedback
  • Assignee deleted (Yusuke Endoh)

See #5780.

Yusuke Endoh mame@tsg.ne.jp

#13 Updated by Vit Ondruch almost 2 years ago

  • Status changed from Feedback to Closed

The build works with glibc-2.15-37.fc17 in F17.

Also available in: Atom PDF