Bug #6040

Transcoding test failure: Big5 to UTF8 not defined (MinGW)

Added by Luis Lavena about 2 years ago. Updated about 2 years ago.

[ruby-core:42697]
Status:Closed
Priority:Normal
Assignee:Yui NARUSE
Category:build
Target version:1.9.3
ruby -v:ruby 1.9.3p125 (2012-02-16) [i386-mingw32] Backport:

Description

Hello,

While testing 1.9.3-p125 (released), discovered this bug which was not present in previous builds:

100) Error:
testBig5(TestTranscode):
Encoding::UndefinedConversionError: "\xA1@" from Big5 to UTF-8
C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby
19/test/ruby/testtranscode.rb:54:in encode'
C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby_1_9/test/ruby/test_transcode.rb:54:in
checkbothways'
C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby19/test/ruby/testtranscode.rb:1788:in `testBig5'

I can't reproduce this when run in isolation (make test-all TESTS="ruby/test_transcode.rb")

Perhaps this is a fluke?

Thank you


Related issues

Duplicates ruby-trunk - Bug #6034: Error in test_Big5(TestTranscode) Closed 02/16/2012

History

#1 Updated by Jeremy Evans about 2 years ago

I can confirm that this error occurs on both OpenBSD amd64 and i386. This happens both when the whole test suite is run and when just test_transcode is run in isolation.

#2 Updated by Nobuyoshi Nakada about 2 years ago

  • Category changed from core to build
  • Assignee set to Yui NARUSE

I've seen this failure when I made enc/trans/*.c with ruby 1.8, but nothing wrong when made with ruby 1.9 or later.
Therefore, seems a bug in the conversion script.

Or a packaging issue.

#3 Updated by Luis Lavena about 2 years ago

Thank you Nobu and Jeremy, I've used 1.9.3-p0 as base ruby so shouldn't be
that.

I'll try build 1.9.3 branch again tomorrow just to confirm.

Sorry for top posting. Sent from mobile.

#4 Updated by Yui NARUSE about 2 years ago

  • Status changed from Open to Closed

This should be fixed r34650 in trunk / 1.9.3-p127.
Could you check and reopen this if not fixed?

#5 Updated by Luis Lavena about 2 years ago

On Thu, Feb 16, 2012 at 9:55 PM, Yui NARUSE naruse@airemix.jp wrote:

Issue #6040 has been updated by Yui NARUSE.

Status changed from Open to Closed

This should be fixed r34650 in trunk / 1.9.3-p127.
Could you check and reopen this if not fixed?

Sorry, redmine seems to be down so responding to ruby-core directly.

ruby19_3, revision 34660 worked perfectly. Thank you.

This justifies another patchlevel release? Big5 encoding seems
important for eastern languages (chinese) and RubyInstaller seems to
have some userbase there (along with Japan).

Thank you.
--
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

#6 Updated by Yui NARUSE about 2 years ago

Luis Lavena wrote:

On Thu, Feb 16, 2012 at 9:55 PM, Yui NARUSE naruse@airemix.jp wrote:

Issue #6040 has been updated by Yui NARUSE.

Status changed from Open to Closed

This should be fixed r34650 in trunk / 1.9.3-p127.
Could you check and reopen this if not fixed?

Sorry, redmine seems to be down so responding to ruby-core directly.

ruby19_3, revision 34660 worked perfectly. Thank you.

This justifies another patchlevel release? Big5 encoding seems
important for eastern languages (chinese) and RubyInstaller seems to
have some userbase there (along with Japan).

This affect only on packaging.
So I repacked it.

#7 Updated by Luis Lavena about 2 years ago

On Fri, Feb 17, 2012 at 7:47 PM, Yui NARUSE naruse@airemix.jp wrote:

Issue #6040 has been updated by Yui NARUSE.

Luis Lavena wrote:

 This justifies another patchlevel release? Big5 encoding seems
 important for eastern languages (chinese) and RubyInstaller seems to
 have some userbase there (along with Japan).

This affect only on packaging.
So I repacked it.

That means I need to re-download and recompile source?

RubyInstaller 1.9.3-p125 was already released on the assumption the
package was final.

I can't re-release p125 to users, RubyForge do not allow same versions
to be uploaded and there is more than 3K downloads already for the
installers.

Please advice.
--
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

#8 Updated by Yui NARUSE about 2 years ago

(2012/02/18 7:54), Luis Lavena wrote:

On Fri, Feb 17, 2012 at 7:47 PM, Yui NARUSE naruse@airemix.jp wrote:

Issue #6040 has been updated by Yui NARUSE.

Luis Lavena wrote:

This justifies another patchlevel release? Big5 encoding seems
important for eastern languages (chinese) and RubyInstaller seems to
have some userbase there (along with Japan).

This affect only on packaging.
So I repacked it.

That means I need to re-download and recompile source?

RubyInstaller 1.9.3-p125 was already released on the assumption the
package was final.

I can't re-release p125 to users, RubyForge do not allow same versions
to be uploaded and there is more than 3K downloads already for the
installers.

Please advice.

We have some additional patches and current ruby19_3 is p133.
So releasing another patch release is an option.

--
NARUSE, Yui naruse@airemix.jp

#9 Updated by Luis Lavena about 2 years ago

If you could do that will be really appreciated.

Thank you.

Sorry for top posting. Sent from mobile.
On Feb 17, 2012 8:08 PM, "NARUSE, Yui" naruse@airemix.jp wrote:

(2012/02/18 7:54), Luis Lavena wrote:

On Fri, Feb 17, 2012 at 7:47 PM, Yui NARUSE naruse@airemix.jp wrote:

Issue #6040 has been updated by Yui NARUSE.

Luis Lavena wrote:

This justifies another patchlevel release? Big5 encoding seems
important for eastern languages (chinese) and RubyInstaller seems to
have some userbase there (along with Japan).

This affect only on packaging.
So I repacked it.

That means I need to re-download and recompile source?

RubyInstaller 1.9.3-p125 was already released on the assumption the
package was final.

I can't re-release p125 to users, RubyForge do not allow same versions
to be uploaded and there is more than 3K downloads already for the
installers.

Please advice.

We have some additional patches and current ruby19_3 is p133.
So releasing another patch release is an option.

NARUSE, Yui naruse@airemix.jp

Also available in: Atom PDF