Project

General

Profile

Actions

Feature #6111

closed

Request for making ruby multiarchable

Added by Hanmac (Hans Mackowiak) over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:43066]

Description

i ask to make it possible to install ruby in more multiarch compatible dirs ...
with configure allone it is not possible

so the libs where are named /usr/lib/libruby(version) should go to /usr/lib/(arch)/libruby(version)

for the config.h with is not arch-indipent it should go to /usr/include/(arch)/ruby/(version)/config.h

the stdlib should (if not gemized) go to /usr/lib/(arch)/ruby/(version)
(maybe the indipent rb files to /usr/lib/ruby/(version))

and the vendor_ruby path should be splitted
for the .so files: /usr/lib/(arch)/ruby/vendor_ruby/(version)
for the .rb files: /usr/lib/ruby/vendor_ruby/(version)

(arch) depends on the system, so my system has "x86_64-linux-gnu" and "i386-linux-gnu"

Actions

Also available in: Atom PDF