Project

General

Profile

Actions

Bug #6121

closed

[[Ruby 1.9:]] Etc.sysconfdir hides sysconfdir on windows

Added by mpapis (Michal Papis) over 10 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-linux]
[ruby-core:43110]

Description

While checking on this issue https://gist.github.com/1981223 I found out that Etc.sysconfdir is inconsistently behaving between Linux and Windows.

This issue is related to rubygems also: https://github.com/rubygems/rubygems/pull/291

On linux you can change sysconfdir with:
--sysconfdir
--prefix
and the calculated path will be available for rubygems and via Etc.sysconfdir

But on Windows users have no option to force a sysconfdir, they will always use default location (~ C:\Documents and Settings\All Users\Application Data).

Also this is not consistent to the documentation header for this function.

Is this intended behavior ?

I could see few occasions where it should be supported to allow switching to system location even --prefix / --sysconfdir was used, but this should be rather configurable not a forced setting.

Even if this is not being implemented/fixed could I get a statement if it is good for rubygems to follow Etc.sysconfdir behavior or it should rather using RbConfig::CONFIG['sysconfdir'] ?

Actions

Also available in: Atom PDF