Bug #6221

OpenSSL 1.0.1 is breaking the drb test suite

Added by Bohuslav Kabrda about 2 years ago. Updated over 1 year ago.

[ruby-core:43844]
Status:Closed
Priority:Normal
Assignee:Masatoshi Seki
Category:-
Target version:1.9.3
ruby -v:ruby 1.9.3p125 (2011-10-30) [x86_64-linux] Backport:

Description

Hi,
I'm having problem with running drbssl tests with Ruby 1.9.3.p125 and OpenSSL 1.0.1, originally reported at [1]. Martin Bosslet told me to open this new issue for drbssl. So here is the problem:

$ make test-all TESTS="test/drb/testdrbssl.rb"
/builddir/build/BUILD/ruby-1.9.3-p125/lib/drb/ssl.rb:185: warning: SSL
accept returned=1 errno=0 state=SSLv3 write key exchange A: EVP lib (OpenSSL::SSL::SSLError)
(I previously set config[:verbose] = true in utarraydrbssl.rb, to see this message.)

I'm reproduce this on Fedora 17/rawhide only with OpenSSL 1.0.1.

Thanks!

[1] https://bugs.ruby-lang.org/issues/6089#note-9


Related issues

Related to ruby-trunk - Bug #6036: Test failures in Fedora Rawhide/17 Closed 02/26/2012

Associated revisions

Revision 35434
Added by Akira Tanaka almost 2 years ago

History

#1 Updated by Yusuke Endoh almost 2 years ago

  • Status changed from Open to Assigned

#2 Updated by Vit Ondruch almost 2 years ago

This issue is still present. Testing with ruby 2.0.0dev (2012-04-17 trunk 35368) [x86_64-linux]

#3 Updated by Akira Tanaka almost 2 years ago

I found http://rt.openssl.org/Ticket/Display.html?id=2769 .

How about the following patch?

Index: lib/drb/ssl.rb

--- lib/drb/ssl.rb (revision 35430)
+++ lib/drb/ssl.rb (working copy)
@@ -54,7 +54,7 @@ module DRb
return
end

  • rsa = OpenSSL::PKey::RSA.new(512){|p, n|
  • rsa = OpenSSL::PKey::RSA.new(1024){|p, n| next unless self[:verbose] case p when 0; $stderr.putc "." # BNgenerateprime

#4 Updated by Vit Ondruch almost 2 years ago

akr (Akira Tanaka) wrote:

How about the following patch?

It seems it fixes my issues. I cannot reproduce the test error any more with the patch applied.

#5 Updated by Akira Tanaka almost 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r35434.
Bohuslav, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


#6 Updated by Akira Tanaka almost 2 years ago

I committed the patch.

Note that the link I shown needs user and pass parameters as:
http://rt.openssl.org/Ticket/Display.html?id=2769&user=guest&pass=guest

Also available in: Atom PDF