Project

General

Profile

Bug #6036

Test failures in Fedora Rawhide/17

Added by Anonymous almost 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-linux]
Backport:
[ruby-core:42685]

Description

Hi, I'm getting these test failures [1] on both Fedora 17 and Rawhide. The tests unfortunately don't run all, because there is probably an endless loop in one of them, which I can't reproduce when running tests separately (is there a way to output each test file in 'make test', so that I can find the file with the endless loop?).
BTW I'm running tests with GDBM 1.10 and some tests are skipped claiming I have GDBM 1.8 - which is probably an issue with the regexps matching GDBM version.

Regards,
Bohuslav "Slavek" Kabrda

[1] https://gist.github.com/1845285


Subtasks

Bug #6089: Test suite fails with OpenSSL 1.0.1ClosedMartinBosslet (Martin Bosslet)Actions

Related issues

Related to Ruby master - Bug #6221: OpenSSL 1.0.1 is breaking the drb test suiteClosed03/29/2012Actions

Associated revisions

Revision d698ea89
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@34646 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 34646
Added by akr (Akira Tanaka) almost 8 years ago

  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Revision 35586754
Added by naruse (Yui NARUSE) almost 8 years ago

merge revision(s) 34646:

    * test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior.
      reported by Bohuslav Kabrda.
      [ruby-core:42685] [ruby-trunk - Bug #6036]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@34653 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

History

#1

Updated by akr (Akira Tanaka) almost 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r34646.
Bohuslav, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • test/dbm/test_dbm.rb: fix skip condition for libgdbm 1.8.0 or prior. reported by Bohuslav Kabrda. [ruby-core:42685] [Bug #6036]

Updated by Anonymous almost 8 years ago

Well, thanks for fixing the gdbm support, but the other 16 failures and 20 errors are the main reason why I reported the bug... Could you have a look at that?
Thanks.

Updated by naruse (Yui NARUSE) almost 8 years ago

  • Status changed from Closed to Assigned
  • Assignee set to vo.x (Vit Ondruch)

Bohuslav Kabrda wrote:

Well, thanks for fixing the gdbm support, but the other 16 failures and 20 errors are the main reason why I reported the bug... Could you have a look at that?
Thanks.

Vit, could you inspect this?

Updated by vo.x (Vit Ondruch) almost 8 years ago

Tests passes with following command: "make check TESTS="-v -x test_pathname.rb -x test_drbssl.rb -x test_parse.rb -x test_x509cert.rb"

The test_drbssl.rb and test_x509cert.rb might be related to the OpenSSL changes?

Updated by vo.x (Vit Ondruch) almost 8 years ago

The test_pathname appears to hang somewhere. The TestPathname#test_pathsubext_510 is the last output which appears in my log, however there might be some entries lost due to not flushed log.

Updated by akr (Akira Tanaka) almost 8 years ago

2012/2/20 Vit Ondruch v.ondruch@tiscali.cz:

The test_pathname appears to hang somewhere. The TestPathname#test_pathsubext_510 is the last output which appears in my log, however there might be some entries lost due to not flushed log.

I installed Fedora but I couldn't reproduce the problem.

% ./ruby test/pathname/test_pathname.rb
Run options:

# Running tests:

...(snip)...

Finished tests in 0.520247s, 505.5290 tests/s, 1039.8904 assertions/s.

263 tests, 541 assertions, 0 failures, 0 errors, 0 skips
% ./ruby -v
ruby 1.9.3p134 (2012-02-19 revision 34690) [i686-linux]
% lsb_release -a
LSB Version: :core-4.0-ia32:core-4.0-noarch
Distributor ID: Fedora
Description: Fedora release 18 (Rawhide)
Release: 18
Codename: Rawhide
--
Tanaka Akira

Updated by vo.x (Vit Ondruch) almost 8 years ago

Akira Tanaka wrote:

2012/2/20 Vit Ondruch v.ondruch@tiscali.cz:

The test_pathname appears to hang somewhere. The TestPathname#test_pathsubext_510 is the last output which appears in my log, however there might be some entries lost due to not flushed log.

I installed Fedora but I couldn't reproduce the problem.

% ./ruby test/pathname/test_pathname.rb
Run options:

# Running tests:

...(snip)...

Finished tests in 0.520247s, 505.5290 tests/s, 1039.8904 assertions/s.

263 tests, 541 assertions, 0 failures, 0 errors, 0 skips
% ./ruby -v
ruby 1.9.3p134 (2012-02-19 revision 34690) [i686-linux]
% lsb_release -a
LSB Version: :core-4.0-ia32:core-4.0-noarch
Distributor ID: Fedora
Description: Fedora release 18 (Rawhide)
Release: 18
Codename: Rawhide
--
Tanaka Akira

I am afraid that the test results differs if you run the whole test suite in once or if you run just part of the test suite, as you did.

Updated by akr (Akira Tanaka) almost 8 years ago

2012/2/22 Vit Ondruch v.ondruch@tiscali.cz:

I am afraid that the test results differs if you run the whole test suite in once or if you run just part of the test suite, as you did.

I see.

The hang is reproduced on my environment.

However the hang is occur at TestProcess#test_abort, not
TestPathname#test_pathsubext_510.

|TestProc#test_to_proc = 0.00 s = .
|TestProc#test_to_s = 0.00 s = .
|TestProcess#test_abort =
C/home/akr/ruby/193/ruby/test/drb/ut_array_drbssl.rb:22:in join':
Interrupt
| from /home/akr/ruby/193/ruby/test/drb/ut_array_drbssl.rb:22:in
'
|/home/akr/ruby/193/ruby/test/drb/ut_drb_drbssl.rb:23:in join': Interrupt
| from /home/akr/ruby/193/ruby/test/drb/ut_drb_drbssl.rb:23:in
'
|
|
|Finished tests in 3031.769106s, 2.1611 tests/s, 593.4136 assertions/s.
|
| 1) Failure:
|test_dsig_algorithm_mismatch(OpenSSL::TestX509Certificate)
[/home/akr/ruby/193/ruby/test/openssl/test_x509cert.rb:175]:
|OpenSSL::X509::CertificateError expected but nothing was raised.
|...

After C, bactrace shows drb.

I think the problem is caused by drb tests.
--
Tanaka Akira

Updated by vo.x (Vit Ondruch) almost 8 years ago

Akira Tanaka wrote:

2012/2/22 Vit Ondruch v.ondruch@tiscali.cz:

I am afraid that the test results differs if you run the whole test suite in once or if you run just part of the test suite, as you did.

I see.

The hang is reproduced on my environment.

However the hang is occur at TestProcess#test_abort, not
TestPathname#test_pathsubext_510.

Yes, that might be. I just noted that the "TestPathname#test_pathsubext_510" was last entry in my log, so there might be other tests passed, but not flushed yet.

|TestProc#test_to_proc = 0.00 s = .
|TestProc#test_to_s = 0.00 s = .
|TestProcess#test_abort =
C/home/akr/ruby/193/ruby/test/drb/ut_array_drbssl.rb:22:in join':
Interrupt
| from /home/akr/ruby/193/ruby/test/drb/ut_array_drbssl.rb:22:in
'
|/home/akr/ruby/193/ruby/test/drb/ut_drb_drbssl.rb:23:in join': Interrupt
| from /home/akr/ruby/193/ruby/test/drb/ut_drb_drbssl.rb:23:in
'
|
|
|Finished tests in 3031.769106s, 2.1611 tests/s, 593.4136 assertions/s.
|
| 1) Failure:
|test_dsig_algorithm_mismatch(OpenSSL::TestX509Certificate)
[/home/akr/ruby/193/ruby/test/openssl/test_x509cert.rb:175]:
|OpenSSL::X509::CertificateError expected but nothing was raised.
|...

After C, bactrace shows drb.

I think the problem is caused by drb tests.
--
Tanaka Akira

That makes sense. I now testing with drb tests disabled, and it does not hang.

Updated by vo.x (Vit Ondruch) almost 8 years ago

It seems that the errors are due to updated openssl library: openssl-1.0.1-0.1.beta2.fc17 ... there is a lot of errors around, Python, MySql ...

Updated by vo.x (Vit Ondruch) almost 8 years ago

It seems that the patch [1] changes the behavior of openssl and makes the test_x509cert.rb fail:

1) Failure:
test_dsig_algorithm_mismatch(OpenSSL::TestX509Certificate) [test/openssl/test_x509cert.rb:175]:
OpenSSL::X509::CertificateError expected but nothing was raised.

I also notified Fedora's openssl maintainer about these issues [2].

[1] http://cvs.openssl.org/filediff?f=openssl/crypto/asn1/a_sign.c&v1=1.21.4.1&v2=1.21.4.2
[2] https://bugzilla.redhat.com/show_bug.cgi?id=797217

Updated by naruse (Yui NARUSE) almost 8 years ago

Could you make another ticket ans assign it to Martin Bo├člet about openssl?

Updated by vo.x (Vit Ondruch) over 7 years ago

  • Status changed from Assigned to Closed

Since the remaining issues were reported in separate issues #6089, #6221, I'm closing this ticket

Also available in: Atom PDF