Bug #6851

Result of File.stat("c:/...") is different from 1.9.3

Added by Heesob Park over 2 years ago. Updated over 2 years ago.

[ruby-core:47103]
Status:Closed
Priority:Normal
Assignee:Usaku NAKAMURA
ruby -v:ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100] Backport:

Description

What is the correct result of File.stat("c:/...") on Windows?

File#stat for path like "c:/..." succeeds on trunk 36676.

C:>ruby -ve 'p File.stat("c:/...")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

C:>ruby -ve 'p File.stat("c:/....")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

C:>ruby -ve 'p File.stat("c:/..../..")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

But, File#stat raises exception on Ruby 1.9.3.

C:\Ruby193\bin>ruby -ve 'p File.stat("c:/...")
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-mingw32]
-e:1:in stat': Invalid argument - c:/... (Errno::EINVAL)
from -e:1:in
'

C:\Ruby193\bin>ruby -ve 'p File.stat("c:/....")
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-mingw32]
-e:1:in stat': No such file or directory - c:/.... (Errno::ENOENT)
from -e:1:in
'

Associated revisions

Revision 36696
Added by Usaku NAKAMURA over 2 years ago

  • win32/win32.c (check_valid_dir): reject "..." as directory name. [Bug #6851]

Revision 36696
Added by Usaku NAKAMURA over 2 years ago

  • win32/win32.c (check_valid_dir): reject "..." as directory name. [Bug #6851]

History

#1 Updated by Usaku NAKAMURA over 2 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Assignee set to Hiroshi Shirosaki
  • Target version set to 2.0.0

It's bug.

#2 Updated by Hiroshi Shirosaki over 2 years ago

The behavior is same (not raises exception) as before r36668.

C:>ruby -ve "p File.stat('C:/...')"
ruby 2.0.0dev (2012-08-08 trunk 36657) [i386-mswin32_100]
#

C:>ruby -ve "p File.stat('C:/....')"
ruby 2.0.0dev (2012-08-08 trunk 36657) [i386-mswin32_100]
#

That seems due to r34205 and r34216.
Revert will solve this issue, but #5819 is not solved on the following corner case.
I think revert might be better. What do you think?

x:\ is empty drive. (ramdisk)

this case is ok

C:>miniruby -I. -e "p File.stat('x:/')"
#

but this case fails

C:>miniruby -I. -e "p File.stat('x:/.../..')"
-e:1:in stat': No such file or directory - x:/.../.. (Errno::ENOENT)
from -e:1:in
'

diff --git a/win32/win32.c b/win32/win32.c
index de655df..11f20ba 100644
--- a/win32/win32.c
+++ b/win32/win32.c
@@ -4562,15 +4562,6 @@ check_valid_dir(const WCHAR *path)
if (wcsstr(path, L"...") == NULL)
return 0;

  • /* if the specified path is the root of a drive and the drive is empty, */
  • /* FindFirstFile() returns INVALID_HANDLE_VALUE. */
  • if (!GetFullPathNameW(path, sizeof(full) / sizeof(WCHAR), full, &dmy)) {
  • errno = map_errno(GetLastError());
  • return -1;
  • }
  • if (full[1] == L':' && !full[3] && GetDriveTypeW(full) != DRIVE_NO_ROOT_DIR)

- return 0;

 fh = open_dir_handle(path, &fd);
 if (fh == INVALID_HANDLE_VALUE)
return -1;

#3 Updated by Luis Lavena over 2 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Hiroshi Shirosaki to Usaku NAKAMURA

=begin
h.shirosaki (Hiroshi Shirosaki) wrote:

The behavior is same (not raises exception) as before r36668.

I can confirm File.stat('C:/...') did not raised exception even before Hiroshi's change.

C:\Users\Luis>ruby -v -e "p File.stat('C:/...')"
ruby 2.0.0dev (2012-08-07 trunk 36647) [i386-mingw32]
#

The changes to use (({GetFileAttributesExW})) are not the cause.

Since this was introduced in r34205 and r34216, perhaps Usa can better describe (({...})) behavior.

Reassigning for feedback.
=end

#4 Updated by Usaku NAKAMURA over 2 years ago

  • Status changed from Feedback to Assigned

Oops...

[Bug #5819] said that File.stat for empty root directory fails.
Of course it was a bug.
"C:/..." problem is an unexpected side effect.

#5 Updated by Usaku NAKAMURA over 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r36696.
Heesob, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • win32/win32.c (check_valid_dir): reject "..." as directory name. [Bug #6851]

#6 Updated by Usaku NAKAMURA over 2 years ago

Hopefully, fixed.

I added some test cases.
Please point out, if I have an oversight.

#7 Updated by Heesob Park over 2 years ago

Hi,

2012/8/14 usa (Usaku NAKAMURA) usa@garbagecollect.jp

Issue #6851 has been updated by usa (Usaku NAKAMURA).

Hopefully, fixed.

I added some test cases.
Please point out, if I have an oversight.


Bug #6851: Result of File.stat("c:/...") is different from 1.9.3
https://bugs.ruby-lang.org/issues/6851#change-28859

Author: phasis68 (Heesob Park)
Status: Closed
Priority: Normal
Assignee: usa (Usaku NAKAMURA)
Category: core
Target version: 2.0.0
ruby -v: ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]

What is the correct result of File.stat("c:/...") on Windows?

File#stat for path like "c:/..." succeeds on trunk 36676.

C:>ruby -ve 'p File.stat("c:/...")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

C:>ruby -ve 'p File.stat("c:/....")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

C:>ruby -ve 'p File.stat("c:/..../..")'
ruby 2.0.0dev (2012-08-10 trunk 36676) [i386-mswin32_100]
#

But, File#stat raises exception on Ruby 1.9.3.

C:\Ruby193\bin>ruby -ve 'p File.stat("c:/...")
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-mingw32]
-e:1:in stat': Invalid argument - c:/... (Errno::EINVAL)
from -e:1:in
'

C:\Ruby193\bin>ruby -ve 'p File.stat("c:/....")
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-mingw32]
-e:1:in stat': No such file or directory - c:/.... (Errno::ENOENT)
from -e:1:in
'

I confirmed the bug is fixed.

I found another odd behavior of File#stat.

File#stat of some directory + ".." always works on Windows even if the
directory is not exists.

C:\work>ruby -e 'p File.stat("./notexist")'
-e:1:in stat': No such file or directory - ./notexist (Errno::ENOENT)
from -e:1:in
'

C:\work>ruby -e 'p File.stat("./notexist/..")'
#

C:\work>ruby -e 'p File.stat("../notexist")'
-e:1:in stat': No such file or directory - ../notexist (Errno::ENOENT)
from -e:1:in
'

C:\work>ruby -e 'p File.stat("../notexist/..")'
#

Here is Linux behavior.

[tmp]$ ruby -ve 'File.stat("./notexist")'
ruby 1.8.7 (2011-02-18 patchlevel 334) [x86_64-linux]
-e:1:in stat': No such file or directory - ./notexist (Errno::ENOENT)
from -e:1
[tmp]$ ruby -ve 'File.stat("./notexist/..")'
ruby 1.8.7 (2011-02-18 patchlevel 334) [x86_64-linux]
-e:1:in
stat': No such file or directory - ./notexist/.. (Errno::ENOENT)
from -e:1

Is this a bug or feature?

Regards,
Park Heesob

#8 Updated by Usaku NAKAMURA over 2 years ago

Is this a bug or feature?

It's a bug, but...
Does anyone challenge to fix this? :)

Also available in: Atom PDF