Project

General

Profile

Bug #696

1.9.0-0 is more faster in factrial test

Added by ariveira (Alexandre Riveira) almost 9 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:19601]

Description

=begin
Mandelbrot factral test (http://www.timestretch.com/FractalBenchmark.html) in 1.9.1 is more slow than 1.9.0, results:

1.9.0-0 => 2.95
1.9.1-preview1 => 4.09

My hardware: pentium M, 1 GB RAM, Centos 5.2, gcc 4.1.2
=end

History

#1 Updated by rogerdpack (Roger Pack) almost 9 years ago

=begin
http://www.timestretch.com/FractalBenchmark.html
is the link
which SVN versions were you using? [or was that just the releases?]
=end

#2 Updated by ariveira (Alexandre Riveira) almost 9 years ago

=begin
I use 1.9.0-0 e 1.9.1-preview1 releases

1.9.0-0 ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.0-0.tar.bz2

1.9.1-preview1 ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.1-preview1.tar.bz2

Alexandre Riveira
=end

#3 Updated by ko1 (Koichi Sasada) over 8 years ago

  • Assignee set to ko1 (Koichi Sasada)

=begin

=end

#4 Updated by yugui (Yuki Sonoda) over 8 years ago

  • Priority changed from Normal to 3
  • Target version changed from 1.9.1 Release Candidate to 2.0.0

=begin

=end

#5 Updated by naruse (Yui NARUSE) almost 8 years ago

  • Status changed from Open to Rejected
  • ruby -v set to 1.9.1

=begin
Not a bug
=end

#6 Updated by mame (Yusuke Endoh) almost 8 years ago

=begin
Even if it is not a bug, a ticket must not be rejected as long as there is a
matter to be checked.

I tested the code on some versions of ruby.

  • 1.9.0-0 0.040320 sec. (wrong result)
  • 1.9.0-5 4.792150 sec.
  • 1.9.1-p0 4.996654 sec.
  • 1.9.1-p243 9.164635 sec.
  • trunk 3.806966 sec.

1.9.0-0 output just empty lines, not mandelbrot set. It seems to be caused
by the following bug (which is already fixed on later versions):

$ ruby-1.9.0-0 -e 'v = -39/40.0; p [v, v-0.5]'
[-0.975, -5.975]

Alexandre, thank you for your report and sorry for our late response. Could
you check whether the issue is still duplicated on trunk? If so, please
reopen this ticket (or register new ticket if you cannot reopen).
=end

Also available in: Atom PDF