Bug #8179

configure.in requires newer Autoconf than specified by AC_PREREQ

Added by David Edelsohn about 1 year ago. Updated about 1 year ago.

[ruby-core:53780]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:trunk Backport:

Description

configure.in states

AC_PREREQ(2.62)

but building with Autoconf-2.64 fails due to missing feature. configure in releases are created using Autoconf-2.69 and that worked on trunk. I do not know the absolute minimum requirement, but 2.62 no longer is correct.

History

#1 Updated by Akira Tanaka about 1 year ago

2013/3/28 edelsohn (David Edelsohn) dje.gcc@gmail.com:

Bug #8179: configure.in requires newer Autoconf than specified by AC_PREREQ
https://bugs.ruby-lang.org/issues/8179

configure.in states

AC_PREREQ(2.62)

but building with Autoconf-2.64 fails due to missing feature. configure in releases are created using Autoconf-2.69 and that worked on trunk. I do not know the absolute minimum requirement, but 2.62 no longer is correct.

It seems autoconf 2.63 works on CentOS:
http://c5664.rubyci.org/~chkbuild/ruby-trunk/log/20130327T190301Z.log.html.gz#autoconf-version
http://c5632.rubyci.org/~chkbuild/ruby-trunk/log/20130327T190322Z.log.html.gz#autoconf-version
--
Tanaka Akira

#2 Updated by Nobuyoshi Nakada about 1 year ago

  • Status changed from Open to Feedback

Could you show what failures occur?

#3 Updated by David Edelsohn about 1 year ago

With Autoconf-2.64 I receive the following error:

configure:1510: error: possibly undefined macro: m4textwrapword
If this token and others are legitimate, please use m4patternallow.
See the Autoconf documentation.

Autoconf-2.69 works.

#4 Updated by Yui NARUSE about 1 year ago

  • Status changed from Feedback to Closed

As far as we know, 2.64 and 2.66 are buggy, so we bumped ACPREREQ to 2.67 (Debian Squeeze uses this) at r40034, thanks.

Also available in: Atom PDF